首页 > 代码库 > POJ 1094-Sorting It All Out(拓扑排序)

POJ 1094-Sorting It All Out(拓扑排序)

Sorting It All Out
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 28055 Accepted: 9689

Description

An ascending sorted sequence of distinct values is one in which some form of a less-than operator is used to order the elements from smallest to largest. For example, the sorted sequence A, B, C, D implies that A < B, B < C and C < D. in this problem, we will give you a set of relations of the form A < B and ask you to determine whether a sorted order has been specified or not.

Input

Input consists of multiple problem instances. Each instance starts with a line containing two positive integers n and m. the first value indicated the number of objects to sort, where 2 <= n <= 26. The objects to be sorted will be the first n characters of the uppercase alphabet. The second value m indicates the number of relations of the form A < B which will be given in this problem instance. Next will be m lines, each containing one such relation consisting of three characters: an uppercase letter, the character "<" and a second uppercase letter. No letter will be outside the range of the first n letters of the alphabet. Values of n = m = 0 indicate end of input.

Output

For each problem instance, output consists of one line. This line should be one of the following three: 

Sorted sequence determined after xxx relations: yyy...y. 
Sorted sequence cannot be determined. 
Inconsistency found after xxx relations. 

where xxx is the number of relations processed at the time either a sorted sequence is determined or an inconsistency is found, whichever comes first, and yyy...y is the sorted, ascending sequence. 

Sample Input

4 6
A<B
A<C
B<C
C<D
B<D
A<B
3 2
A<B
B<A
26 1
A<Z
0 0

Sample Output

Sorted sequence determined after 4 relations: ABCD.
Inconsistency found after 2 relations.
Sorted sequence cannot be determined.
每输入一条边就要用拓扑排序判断一次,如果有环则输出有环,如果多解则继续输入,如果排序已完成则输出排序结果。
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <stack>
using namespace std;
int n, m,in[30],cnt,ma[30][30];
char ans[30];
int top_sort()
{
	stack <int> s;
	int flag = 0;
    cnt=0;
    memset(in,0,sizeof(in));
    for(int i=1;i<=n;i++)
        for(int j=1;j<=n;j++)
        if(ma[i][j])
        in[j]++;
	for (int i = 1; i <= n; i++)
		if (in[i] == 0)
		{
			s.push(i);
		}

	while (!s.empty())
	{
		if (s.size() > 1)
		{
			flag = 1;
		}

		int u = s.top();
		s.pop();
		ans[cnt++] = u - 1 + 'A';
		for (int i = 1; i <=n; i++)
		{
			if(ma[u][i])
			{
			    in[i]--;
			    if(in[i]==0)
                    s.push(i);
			}
		}
	}
	if (cnt < n)
	{
		return 0;
	}
	else
		if (flag == 1)
		{
			return 1;
		}
		else
		{
			return 2;
		}
}
int main()
{
	char c[5];

	while (~scanf("%d%d", &n, &m))
	{
		if (!m && !n)
		{
			break;
		}
		int ok = 1;memset(ma,0,sizeof(ma));
		for (int i = 1; i <= m; i++)
		{
			scanf("%s", c);
			if(!ok)continue;
			int u = c[2] - 'A' + 1, v = c[0] - 'A' + 1;
			ma[u][v]=1;
			int x = top_sort();

			if (x == 2)
			{
				printf("Sorted sequence determined after %d relations: ", i);

				for (int i = cnt - 1; i >= 0; i--)
				{
					printf("%c", ans[i]);
				}

				printf(".\n");
				ok = 0;
			}
			else
				if (x == 0)
				{
					printf("Inconsistency found after %d relations.\n", i);
					ok = 0;
				}
		}
		if (ok)
		{
			printf("Sorted sequence cannot be determined.\n");
		}
	}

	return 0;
}


POJ 1094-Sorting It All Out(拓扑排序)