首页 > 代码库 > hdu-Bitset

hdu-Bitset

Bitset

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 12693    Accepted Submission(s): 9772


Problem Description
Give you a number on base ten,you should output it on base two.(0 < n < 1000)
 

Input
For each case there is a postive number n on base ten, end of file.
 

Output
For each case output a number on base two.
 

Sample Input
1 2 3
 

Sample Output
1 10 11
 

代码:
#include<stdio.h>
int main()
{
	int n,a[100];
	while(~scanf("%d",&n))
	{
		int i=0,j;
		while(n)
		{
			a[i++]=n%2;
			n/=2;
		}
		for(j=i-1;j>0;--j)
		{
		   if(a[j]!=0)
		   break;
		}
		for(;j>=0;--j)
		{
			printf("%d",a[j]);
		}
		printf("\n");
	}
	return 0;
}

hdu-Bitset