首页 > 代码库 > Problem A: 分数类的输出
Problem A: 分数类的输出
Description
Input
Output
Sample Input
Sample Output
HINT
Append Code
#include<iostream>
#include<iomanip>
using namespace std;
int gcd(int a,int b) //辗转相除法;大除以小
{
return b==0?a:gcd(b,a%b);//分母为零不能继续
}
class Fract
{
private:
int x,y;
public:
Fract(int a=0,int b=0):x(a),y(b)
{
int flager=1;
if(y<0)
{
y=-y;
x=-x;
}
if(x<0)
{
flager=-1;
x=-x;
}
int flag=gcd(max(x,y),min(x,y));//max min,节约
x/=flag;
y/=flag;
if(flager==-1)//前方输出
x=-x;
}
void show()
{
if(x==0||y==1)
cout<<x<<endl;
else
cout<<x<<‘/‘<<y<<endl;
}
};
#include <cstdio>
int main()
{
int n, m;
while(cin >> n >> m)
{
Fract fr(n, m);
fr.show();
}
}
Problem A: 分数类的输出