首页 > 代码库 > hdu 1069 Monkey and Banana (结构体排序,也属于简单的dp)

hdu 1069 Monkey and Banana (结构体排序,也属于简单的dp)

Monkey and Banana

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7770    Accepted Submission(s): 4003


Problem Description
A group of researchers are designing an experiment to test the IQ of a monkey. They will hang a banana at the roof of a building, and at the mean time, provide the monkey with some blocks. If the monkey is clever enough, it shall be able to reach the banana by placing one block on the top another to build a tower and climb up to get its favorite food.

The researchers have n types of blocks, and an unlimited supply of blocks of each type. Each type-i block was a rectangular solid with linear dimensions (xi, yi, zi). A block could be reoriented so that any two of its three dimensions determined the dimensions of the base and the other dimension was the height.

They want to make sure that the tallest tower possible by stacking blocks can reach the roof. The problem is that, in building a tower, one block could only be placed on top of another block as long as the two base dimensions of the upper block were both strictly smaller than the corresponding base dimensions of the lower block because there has to be some space for the monkey to step on. This meant, for example, that blocks oriented to have equal-sized bases couldn‘t be stacked.

Your job is to write a program that determines the height of the tallest tower the monkey can build with a given set of blocks.
 

Input
The input file will contain one or more test cases. The first line of each test case contains an integer n,
representing the number of different blocks in the following data set. The maximum value for n is 30.
Each of the next n lines contains three integers representing the values xi, yi and zi.
Input is terminated by a value of zero (0) for n.
 

Output
For each test case, print one line containing the case number (they are numbered sequentially starting from 1) and the height of the tallest possible tower in the format "Case case: maximum height = height".
 

Sample Input
1 10 20 30 2 6 8 10 5 5 5 7 1 1 1 2 2 2 3 3 3 4 4 4 5 5 5 6 6 6 7 7 7 5 31 41 59 26 53 58 97 93 23 84 62 64 33 83 27 0
 

Sample Output
Case 1: maximum height = 40 Case 2: maximum height = 21 Case 3: maximum height = 28 Case 4: maximum height = 342
 

Source
University of Ulm Local Contest 1996
 

题意:
猴子要想吃到自己想吃的水果,需要构建一个塔,构建塔的时候,上面的木块的长宽高,都需要比下面的大。就是结构体排序。
代码如下:
#include<stdio.h>
#include<algorithm>
using namespace std;
struct block{
	int x,y,z;
}a[222];
int s[222];
int cmp(block a,block b) 
{
	if(a.x==b.x)
	return a.y<b.y;
	else
	return a.x<b.x;
}
int main()
{
	int n;
	int c=1,m,i,j,x,y,z;
	while(~scanf("%d",&n),n)
	{
		m=1;
		int maxi=0;
		for(i=0;i<n;i++)//将所有的可能性都填入a数组中 
		{
			scanf("%d%d%d",&x,&y,&z);
			a[m].x=x,a[m].y=y,a[m].z=z;
			m++;
			a[m].x=x,a[m].y=z,a[m].z=y;
			m++;
			a[m].x=y,a[m].y=x,a[m].z=z;
			m++;
			a[m].x=y,a[m].y=z,a[m].z=x;
			m++;
			a[m].x=z,a[m].y=y,a[m].z=x;
			m++;
			a[m].x=z,a[m].y=x,a[m].z=y;
			m++;
		}
		m-=1;//因为最后多加了一 
		sort(a,a+m,cmp);
		for(i=1;i<=m;i++)
		s[i]=a[i].z;
		for(i=1;i<=m;i++)
		{
			for(j=1;j<=i;j++)
			{
				if(a[j].x<a[i].x&&a[j].y<a[i].y&&s[i]<s[j]+a[i].z)//需要长宽都 小于下面的,高度越高越好 
				{
					s[i]=s[j]+a[i].z;
					if(maxi<s[i])//找出最高的高度 
					maxi=s[i];
				}
			}
		}
		printf("Case %d: maximum height = %d\n",c++,maxi);
	}
	return 0;
}



hdu 1069 Monkey and Banana (结构体排序,也属于简单的dp)