首页 > 代码库 > Fence(poj1821)
Fence(poj1821)
Fence
Time Limit: 1000MS | Memory Limit: 30000K | |
Total Submissions: 4705 | Accepted: 1489 |
Description
A team of k (1 <= K <= 100) workers should paint a fence which contains N (1 <= N <= 16 000) planks numbered from 1 to N from left to right. Each worker i (1 <= i <= K) should sit in front of the plank Si and he may paint only a compact interval (this means that the planks from the interval should be consecutive). This interval should contain the Si plank. Also a worker should not paint more than Li planks and for each painted plank he should receive Pi $ (1 <= Pi <= 10 000). A plank should be painted by no more than one worker. All the numbers Si should be distinct.
Being the team‘s leader you want to determine for each worker the interval that he should paint, knowing that the total income should be maximal. The total income represents the sum of the workers personal income.
Write a program that determines the total maximal income obtained by the K workers.
Being the team‘s leader you want to determine for each worker the interval that he should paint, knowing that the total income should be maximal. The total income represents the sum of the workers personal income.
Write a program that determines the total maximal income obtained by the K workers.
Input
The input contains:
Input
N K
L1 P1 S1
L2 P2 S2
...
LK PK SK
Semnification
N -the number of the planks; K ? the number of the workers
Li -the maximal number of planks that can be painted by worker i
Pi -the sum received by worker i for a painted plank
Si -the plank in front of which sits the worker i
Input
N K
L1 P1 S1
L2 P2 S2
...
LK PK SK
Semnification
N -the number of the planks; K ? the number of the workers
Li -the maximal number of planks that can be painted by worker i
Pi -the sum received by worker i for a painted plank
Si -the plank in front of which sits the worker i
Output
The output contains a single integer, the total maximal income.
Sample Input
8 43 2 23 2 33 3 51 1 7
Sample Output
17
Hint
Explanation of the sample:
the worker 1 paints the interval [1, 2];
the worker 2 paints the interval [3, 4];
the worker 3 paints the interval [5, 7];
the worker 4 does not paint any plank
the worker 1 paints the interval [1, 2];
the worker 2 paints the interval [3, 4];
the worker 3 paints the interval [5, 7];
the worker 4 does not paint any plank
思路:dp+单调队列;
首先我们要对原来的点按顺序排,然后dp[i][j]表示前i个人喷漆到j个位置结束的最大值,那么转移方程是dp[i][j] = max(dp[i-1][j],dp[i-1][j-s]+s*ans.p);这样n^3肯定不行,然后方程可写为dp[i-1][k]+(j-k)*ans.p=dp[i-1][k]-k*ans.p+j*ans.p,因为第二层循环中的j是不变的,(max(0,j-ans.l)<=k<ans.s),那么ans.l定,ans.s定,当j增大时区间范围减小,然后单调队列维护下最大值即可。复杂度O(n*m);
1 #include<stdio.h> 2 #include<algorithm> 3 #include<iostream> 4 #include<string.h> 5 #include<stdlib.h> 6 #include<queue> 7 #include<stack> 8 using namespace std; 9 typedef long long LL;10 typedef struct node11 {12 int cost;13 int id;14 bool operator<(const node &cx)const15 {16 if(cx.cost == cost)return cx.id < id;17 else return cx.cost>cost;18 }19 } ak;20 typedef struct pp21 {22 int l,p,s;23 } ss;24 bool cmp(pp p,pp q)25 {26 return p.s<q.s;27 }28 priority_queue<ak>que;29 ss ans[105];30 int dp[105][16005];31 ak quq[2*16005];32 int main(void)33 {34 int n,m;35 while(scanf("%d %d",&n,&m)!=EOF)36 {37 int j;38 int i;39 int maxx = 0;40 for(i = 1; i <= m; i++)41 scanf("%d %d %d",&ans[i].l,&ans[i].p,&ans[i].s);42 sort(ans+1,ans+1+m,cmp);43 memset(dp,0,sizeof(dp));44 for(i = 1; i <= m; i++)45 {46 int head = 16001;47 int rail = 16000;48 for(j = 0; j < ans[i].s; j++)49 {50 dp[i][j] = dp[i-1][j];51 ak acc;52 acc.cost = dp[i-1][j]-j*ans[i].p;53 acc.id = j;54 if(head>rail)55 quq[--head] = acc;56 else57 {58 ak cpp = quq[rail];59 while(cpp.cost < acc.cost)60 {61 rail--;62 if(rail<head)63 {64 break;65 }66 cpp = quq[rail];67 }68 quq[++rail] = acc;69 }70 maxx = max(maxx,dp[i][j]);71 }72 for(j = ans[i].s; j <= min(n,ans[i].l+ans[i].s-1); j++)73 {74 dp[i][j] = max(dp[i-1][j],dp[i][j]);75 int minn = max(0,j-ans[i].l);76 while(head<=rail)77 {78 ak acc = quq[head];79 if(acc.id < minn)80 {81 head++;82 }83 else84 {85 dp[i][j] = max(dp[i][j],acc.cost+j*ans[i].p);86 break;87 }88 }89 maxx = max(maxx,dp[i][j]);90 }91 for(j = min(n,ans[i].l+ans[i].s-1)+1; j <= n; j++)92 {93 dp[i][j] = dp[i-1][j];94 maxx = max(maxx,dp[i][j]);95 }}96 printf("%d\n",maxx);97 }98 return 0;}
Fence(poj1821)
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。