首页 > 代码库 > Graph(2014辽宁ACM省赛)

Graph(2014辽宁ACM省赛)


问题 F: Graph

时间限制: 1 Sec  内存限制: 128 MB
提交: 30  解决: 5
[提交][状态][论坛]

题目描述

Your task is to judge whether a regular polygon can be drawn only by straightedge and compass.

The length of the straightedge is infinite.

The width of the compass is infinite.

The straightedge does not have scale.

输入

There are several test cases. Each test case contains a positive integer n (3<=n<=10^9). The input will be ended by the End Of File.

输出

If the regular polygon with n sides can be drawn only by straightedge and compass, output YES in one line, otherwise, output NO in one line.

样例输入

34567

样例输出

YESYESYESYESNO



坑大爹的一题,该死的费马数。。。。。。

p=2^n;
或 p=(2^n)*m; m为若干个不相同的费马数的积
//满足要求的边为 (2^n)*p p为费马素数
#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        while(n%2==0)
        {
            n/=2;
        }
        if(n==1)
        {
            printf("YES\n");
            continue;
        }
        if(n%3==0)
            n/=3;
        if(n%5==0)
            n/=5;
        if(n%17==0)
            n/=17;
        if(n%257==0)
            n/=257;
        if(n%65537==0)
            n/=65537;
        if(n==1)
        {
            printf("YES\n");
        }
        else
            printf("NO\n");
    }
    return 0;
}