首页 > 代码库 > 几道算法题
几道算法题
1.
Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6
answer:
#include<stdio.h>
#include<string.h>
int main()
{
int t,n,i,j,a,k,l;
int sum[100000+10]={0};
int left,right,min,best;
scanf("%d",&t);
for(k=1;k<=t;k++)
{
scanf("%d",&n);
for(i=1;i<=n;i++) {scanf("%d",&a); sum[i]=sum[i-1]+a;}
left=-1; right=-1;
min=100000001; best=-100000001; //??
for(j=1;j<=n;j++) //以j结尾的子串
{
if(sum[j-1]<min) {min=sum[j-1]; l=j;}
if(sum[j]-min>best)
{
best=sum[j]-min;
left=l;
right=j;
}
}
if(k==t) printf("Case %d:\n%d %d %d\n",k,best,left,right);
else printf("Case %d:\n%d %d %d\n\n",k,best,left,right);
}
return 0;
}
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。