首页 > 代码库 > hdu2102

hdu2102

题目链接:

http://acm.hdu.edu.cn/showproblem.php?pid=2102

题目:

A计划

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8731    Accepted Submission(s): 2076


Problem Description
可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后,而今,不幸的她再一次面临生命的考验。魔王已经发出消息说将在T时刻吃掉公主,因为他听信谣言说吃公主的肉也能长生不老。年迈的国王正是心急如焚,告招天下勇士来拯救公主。不过公主早已习以为常,她深信智勇的骑士LJ肯定能将她救出。
现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示。骑士们一进入时空传输机就会被转到另一层的相对位置,但如果被转到的位置是墙的话,那骑士们就会被撞死。骑士们在一层中只能前后左右移动,每移动一格花1时刻。层间的移动只能通过时空传输机,且不需要任何时间。
 

Input
输入的第一行C表示共有C个测试数据,每个测试数据的前一行有三个整数N,M,T。 N,M迷宫的大小N*M(1 <= N,M <=10)。T如上所意。接下去的前N*M表示迷宫的第一层的布置情况,后N*M表示迷宫第二层的布置情况。
 

Output
如果骑士们能够在T时刻能找到公主就输出“YES”,否则输出“NO”。
 

Sample Input
1 5 5 14 S*#*. .#... ..... ****. ...#. ..*.P #.*.. ***.. ...*. *.#..
 

Sample Output
YES
 

Source
HDU 2007-6 Programming Contest
 

Recommend
xhd   |   We have carefully selected several similar problems for you:  1180 1372 1728 1175 2717 
 
这个题目我最开始用数组维护。。。但是一直错,我也不知道在哪里wa了。。。

所以改用标记数组。。。

用bfs。。。。最开始的时候需要预处理一下.。。。。

1:如果两个对面都是传送门则会出现死循环。。。所以要把这两面设置成墙。。。

2:如果传送门的对面是墙 ,则两个设为墙。。。。

然后就是bfs了。。。

</pre><pre code_snippet_id="370769" snippet_file_name="blog_20140530_2_5736025" name="code" class="css">#include <iostream>
#include <cstring>
#include <cstdio>
#include <queue>
#include <cmath>
#include <string>
#include <algorithm>
using namespace std;
struct node
{
    int x,y;
    int step;
    int a;
}start;
int dx[4]={0,0,-1,1};
int dy[4]={-1,1,0,0};
int n,m,T,ex,ey,ez;
char map[2][15][15];

bool bfs()
{
    start.x=0,start.y=0, start.a=0, start.step=0;
    node first,next;
    queue<node>q;
    map[0][0][0]='*';
    q.push(start);
    while(!q.empty())
    {
        first=q.front();
        q.pop();
        if(first.step>T) break;
        if(first.x==ex&&first.y==ey&&first.a==ez&&first.step<=T)
            return true;
        for(int i=0; i<4; i++)
        {
            next=first;
            next.x+=dx[i];
            next.y+=dy[i];
            ++next.step;
            if(next.x<0||next.x>=n||next.y<0||next.y>=m) continue;
            if(map[next.a][next.x][next.y]=='#')
            {
                map[next.a][next.x][next.y]='*';
                next.a=(next.a==1)?0:1;
                q.push(next);
            }
            if(map[next.a][next.x][next.y]=='.')
            {
                map[next.a][next.x][next.y]='*';                   q.push(next);
            }
            if(next.a==ez&&next.x==ex&&next.y==ey&&next.step<=T)
                return true;
        }
    }
    return false;
}
int main()
{
    char str[25];
    int t;
    scanf("%d",&t);
    while(t--)
    {
          scanf("%d%d%d",&n,&m,&T);
            for(int k=0;k<2;k++)
                for(int i=0;i<n;i++)
                   {
                       scanf("%s",str);
                       for(int j=0;j<m;j++)
                        {
                           map[k][i][j]=str[j];
                           if(map[k][i][j]=='P')
                               ez=k,ex=i,ey=j;
                        }
                   }
           for(int i=0;i<n;i++)
                 for(int j=0;j<m;j++)
                    {
                        if(map[0][i][j]=='#'&&map[1][i][j]=='#'){ map[0][i][j]='*';map[1][i][j]='*';}
                        if(map[0][i][j]=='*'&&map[1][i][j]=='#'){ map[0][i][j]='*';map[1][i][j]='*';}
                        if(map[0][i][j]=='#'&&map[1][i][j]=='*'){ map[0][i][j]='*';map[1][i][j]='*';}
                    }
        if(bfs())
             printf("YES\n");
        else
             printf("NO\n");
    }
    return 0;
}