首页 > 代码库 > POJ 1159-Palindrome(dp_回文串+滚动数组)

POJ 1159-Palindrome(dp_回文串+滚动数组)

Palindrome
Time Limit:3000MS     Memory Limit:65536KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order to obtain a palindrome. 

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome. 

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from ‘A‘ to ‘Z‘, lowercase letters from ‘a‘ to ‘z‘ and digits from ‘0‘ to ‘9‘. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input

5
Ab3bd

Sample Output

2

题意:让你在原串里面添加最少的字母个数使原串变成回文串。

思路:最少补充的字母个数=原序列的长度-原串和逆串的最长公共子串的长度。dp储存的是从i到j的相同字母的个数。

PS:因为5000*5000肯定超内存,所以在这里引入滚动数组的知识。滚动数组很适合用在二维DP而且是数组在很大时,可以节省内存,消除超内存的隐患!

滚动数组讲解

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <iostream>
#include <algorithm>
#include <set>
#include <queue>

using namespace std;
const int inf=0x3f3f3f3f;

char str1[5010];
char str2[5010];
int dp[2][5010];
int main()
{
    int n,i,j;
    while(~scanf("%d",&n)){
        getchar();
        for(i=1;i<=n;i++){
            scanf("%c",&str1[i]);
            str2[n-i+1]=str1[i];
        }
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
        for(j=1;j<=n;j++){
            if(str1[i]==str2[j])
                dp[i%2][j]=dp[(i-1)%2][j-1]+1;
            else
                dp[i%2][j]=max(dp[(i-1)%2][j],dp[i%2][j-1]);
        }
        printf("%d\n",n-dp[n%2][n]);
    }
    return 0;
}


POJ 1159-Palindrome(dp_回文串+滚动数组)