首页 > 代码库 > hdu 3047 Zjnu Stadium【带权并查集】
hdu 3047 Zjnu Stadium【带权并查集】
In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1--300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1--N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
Input
There are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.
Output
For every case:
Output R, represents the number of incorrect request.
Output R, represents the number of incorrect request.
Sample Input
10 10 1 2 150 3 4 200 1 5 270 2 6 200 6 5 80 4 7 150 8 9 100 4 8 50 1 7 100 9 2 100
Sample Output
2分析:题意是按题目所诉A B X 就是把B放在A的位置编号+X处的位置,关键的一点就是明白如果find(A)!=find(B)则B的祖宗(find(B))的位置应为dis【A】+x-dis【B】,出现冲突的情况是当find(A)==find(B)时dis【B】!=dis【A】+x,这样就清楚了。
- #include<stdio.h>
- #include<string.h>
- #include<algorithm>
- #include<iostream>
- #define maxh 50000+10
- using namespace std;
- int set[maxh],dis[maxh];
- void init(int n)
- {
- for(int i=0;i<=n;i++)
- {
- set[i]=i;
- dis[i]=0;
- }
- }
- int findx(int x)
- {
- if(x==set[x])
- return set[x];
- int p=set[x];
- set[x]=findx(set[x]);
- dis[x]+=dis[p];
- return set[x];
- }
- bool uniom(int x,int y,int m)
- {
- int a=findx(x);
- int b=findx(y);
- if(a==b)
- {
- if(dis[x]+m!=dis[y])
- return false;
- return true;
- }
- else
- {
- set[b]=a;
- dis[b]=dis[x]+m-dis[y];
- return true;
- }
- }
- int main()
- {
- int n,m;
- int A,B,X;
- int ans;
- while(~scanf("%d%d",&n,&m))
- {
- init(n);
- ans=0;
- for(int i=0;i<m;i++)
- {
- scanf("%d%d%d",&A,&B,&X);
- if(!uniom(A,B,X))
- ans++;
- }
- printf("%d\n",ans);
- }
- return 0;
- }
hdu 3047 Zjnu Stadium【带权并查集】
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。