首页 > 代码库 > HDU_3172_带权并查集

HDU_3172_带权并查集

Virtual Friends

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8229    Accepted Submission(s): 2363


Problem Description
These days, you can do all sorts of things online. For example, you can use various websites to make virtual friends. For some people, growing their social network (their friends, their friends‘ friends, their friends‘ friends‘ friends, and so on), has become an addictive hobby. Just as some people collect stamps, other people collect virtual friends. 

Your task is to observe the interactions on such a website and keep track of the size of each person‘s network. 

Assume that every friendship is mutual. If Fred is Barney‘s friend, then Barney is also Fred‘s friend.
 

 

Input
Input file contains multiple test cases. 
The first line of each case indicates the number of test friendship nest.
each friendship nest begins with a line containing an integer F, the number of friendships formed in this frindship nest, which is no more than 100 000. Each of the following F lines contains the names of two people who have just become friends, separated by a space. A name is a string of 1 to 20 letters (uppercase or lowercase).
 

 

Output
Whenever a friendship is formed, print a line containing one integer, the number of people in the social network of the two people who have just become friends.
 

 

Sample Input
1 3 Fred Barney Barney Betty Betty Wilma
 

 

Sample Output
2 3 4
 
带权并查集:也就是可以记录每个集合中元素的个数。
实现方法:在普通并查集中增加dist数组在记录每个父节点的深度(即该集合中元素个数)
#include<iostream>
#include<cstdio>
#include<map>
#include<string>
using namespace std;
#define N 200005

map<string,int>m;
int father[N],dist[N];

int Find(int x)
{
    if(father[x]!=x)
        father[x]=Find(father[x]);
    return father[x];
}

void Merge(int a,int b)
{
    int fa=Find(a);
    int fb=Find(b);
    if(fa!=fb)
    {
        father[fa]=fb;
        dist[fb]+=dist[fa];
    }
    printf("%d\n",dist[fb]);
}

int main()
{
    int t;
    while(scanf("%d",&t)!=EOF)
    {
        while(t--)
        {
            m.clear();
            int n,cnt=1;
            string name1,name2;
            scanf("%d",&n);
            for(int i=1; i<=2*n; i++)
            {
                father[i]=i;
                dist[i]=1;
            }
            while(n--)
            {
                cin>>name1>>name2;
                if(m.find(name1)==m.end())
                    m[name1]=cnt++;
                if(m.find(name2)==m.end())
                    m[name2]=cnt++;
                Merge(m[name1],m[name2]);
            }
        }
    }
    return 0;
}

 

HDU_3172_带权并查集