首页 > 代码库 > HDU 1157
HDU 1157
我竟然在这么水的题目上WA了一次,可是它没说要多组数据啊。我的英语啊!!!上题目:
Problem DescriptionFJ is surveying his herd to find the most average cow. He wants to know how much milk this ‘median‘ cow gives: half of the cows give as much or more than the median; half give as much or less.
Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
Input* Line 1: A single integer N
* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
Output* Line 1: A single integer that is the median milk output.
Sample Input5
2
4
1
3
5
Sample Output3
Hint
INPUT DETAILS:
Five cows with milk outputs of 1..5
OUTPUT DETAILS:
1 and 2 are below 3; 4 and 5 are above 3.
#include <stdio.h>
#define wbx 10005
int a[wbx];
#include <string.h>
#include <algorithm>
using namespace std;
void solve()
{
int n,i;
while(~scanf("%d",&n))
{
memset(a,0,sizeof(a));
for(i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n);
printf("%d\n",a[n/2]);
}
}
int main()
{
solve();
return 0;
}
Given an odd number of cows N (1 <= N < 10,000) and their milk output (1..1,000,000), find the median amount of milk given such that at least half the cows give the same amount of milk or more and at least half give the same or less.
* Lines 2..N+1: Each line contains a single integer that is the milk output of one cow.
5 2 4 1 3 5
3HintINPUT DETAILS: Five cows with milk outputs of 1..5 OUTPUT DETAILS: 1 and 2 are below 3; 4 and 5 are above 3.
#include <stdio.h> #define wbx 10005 int a[wbx]; #include <string.h> #include <algorithm> using namespace std; void solve() { int n,i; while(~scanf("%d",&n)) { memset(a,0,sizeof(a)); for(i=0;i<n;i++) scanf("%d",&a[i]); sort(a,a+n); printf("%d\n",a[n/2]); } } int main() { solve(); return 0; }
HDU 1157
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。