首页 > 代码库 > NYOJ-43 24 Point game-DFS

NYOJ-43 24 Point game-DFS

24 Point game

时间限制:3000 ms  |  内存限制:65535 KB
难度:5
描述

There is a game which is called 24 Point game.

In this game , you will be given some numbers. Your task is to find an expression which have all the given numbers and the value of the expression should be 24 .The expression mustn‘t have any other operator except plus,minus,multiply,divide and the brackets. 

e.g. If the numbers you are given is "3 3 8 8", you can give "8/(3-8/3)" as an answer. All the numbers should be used and the bracktes can be nested. 

Your task in this problem is only to judge whether the given numbers can be used to find a expression whose value is the given number。

输入
The input has multicases and each case contains one line
The first line of the input is an non-negative integer C(C<=100),which indicates the number of the cases.
Each line has some integers,the first integer M(0<=M<=5) is the total number of the given numbers to consist the expression,the second integers N(0<=N<=100) is the number which the value of the expression should be.
Then,the followed M integer is the given numbers. All the given numbers is non-negative and less than 100
输出
For each test-cases,output "Yes" if there is an expression which fit all the demands,otherwise output "No" instead.
样例输入
2
4 24 3 3 8 8
3 24 8 3 3
样例输出
Yes
No
#include<cstdio>
#include<cstring>
#include<cmath>
#include<cstdlib>
#include<iostream>
#include<algorithm>
#include<queue>
#include<stack>
//#define MIN 1e-10
using namespace std;
const double MIN=1e-10;//const double,习惯性的写成const int 导致搞了一个晚上 
double a[10]; 
int n;
double num;
bool DFS(int x)
{
	if(x==n)
	{
		if(fabs(num-a[n])<MIN)
		     return true;
		return false;
	}
	double now,next;
	for(int i=x;i<n;i++)
	{
		for(int j=i+1;j<=n;j++)
		{
			now=a[i];
			next=a[j];
			a[i]=a[x];
			a[j]=now+next;if(DFS(x+1)) return true;
			a[j]=now-next;if(DFS(x+1)) return true;
			a[j]=next-now;if(DFS(x+1)) return true;
			a[j]=now*next;if(DFS(x+1)) return true;
			
			if(next)  //分母不为 0 
			{
				a[j]=now/next;if(DFS(x+1)) return true;
			}
			if(now)   //分母不为 0
			{
				a[j]=next/now;if(DFS(x+1)) return true;
			}
			a[i]=now;
			a[j]=next;
		}
	}
	return false;
}
int main()
{
	int T;
	while(~scanf("%d",&T))
	{
		while(T--)
		{
			memset(a,0,sizeof(a));
			scanf("%d %lf",&n,&num);
			for(int i=1;i<=n;i++)
			{
				scanf("%lf",&a[i]);
			}
			if(DFS(1))
			   cout<<"Yes"<<endl;
			else
			   cout<<"No"<<endl;
		}
	}
	return 0;
}


NYOJ-43 24 Point game-DFS