首页 > 代码库 > xxx定律(杭电oj3782)

xxx定律(杭电oj3782)

xxx定律

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2759    Accepted Submission(s): 2035


Problem Description
对于一个数n,如果是偶数,就把n砍掉一半;如果是奇数,把n变成 3*n+ 1后砍掉一半,直到该数变为1为止。
请计算需要经过几步才能将n变到1,具体可见样例。
 

Input
测试包含多个用例,每个用例包含一个整数n,当n为0 时表示输入结束。(1<=n<=10000)
 

Output
对于每组测试用例请输出一个数,表示需要经过的步数,每组输出占一行。
 

Sample Input
3 1 0
 

Sample Output
5 0
 

Source
浙大计算机研究生复试上机考试-2009年
#include<stdio.h>
int main()
{
	int n,t;
	while(scanf("%d",&n)&&n)
	{
		t=0;
		while(n!=1)
		{
		    if(n&1)
			    n=(n*3+1)/2;
			else
			    n/=2;
			t++;	
		}
		printf("%d\n",t);
	}
	return 0;
} 

xxx定律(杭电oj3782)