首页 > 代码库 > poj 3641 Pseudoprime numbers 【快速幂】

poj 3641 Pseudoprime numbers 【快速幂】

Pseudoprime numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6645 Accepted: 2697

Description

Fermat‘s theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

题意:给出两个数p,a 如果p是素数输出no 否则判断a的p次方对p取模之后是不是等于a

代码:

#include <stdio.h>
#include <math.h>
#define LL __int64

int is_prime(int n){
	if(n < 2) return 0;
	for(int i = 2; i <= sqrt(n+0.0); i++){
		if(n%i == 0) return 0;
	}
	return 1;
}

int fast(int p, int a){
	LL r = p, t = 1, mod = p;
	while(r > 0){
		if(r&1) t = ((t%mod)*(a%mod))%mod;
		a = ((a%mod)*(a%mod))%mod;
		r >>= 1;
	}
	return t%mod;
}

int main(){
	int p, a;
	while(scanf("%d%d", &p, &a), p||a){
		if(is_prime(p)){
			printf("no\n"); continue;
		}
		else if(fast(p, a) == a){
			printf("yes\n");
		}
		else printf("no\n");
	}
	return 0;
} 



poj 3641 Pseudoprime numbers 【快速幂】