首页 > 代码库 > POJ 3070 Fibonacci(矩阵快速幂)

POJ 3070 Fibonacci(矩阵快速幂)

Description

In the Fibonacci integer sequence, F0 = 0, F1 = 1, and Fn = Fn ? 1 + Fn ? 2 for n ≥ 2. For example, the first ten terms of the Fibonacci sequence are:

0, 1, 1, 2, 3, 5, 8, 13, 21, 34, …

An alternative formula for the Fibonacci sequence is

.

Given an integer n, your goal is to compute the last 4 digits of Fn.

Input

The input test file will contain multiple test cases. Each test case consists of a single line containing n (where 0 ≤ n ≤ 1,000,000,000). The end-of-file is denoted by a single line containing the number ?1.

Output

For each test case, print the last four digits of Fn. If the last four digits of Fn are all zeros, print ‘0’; otherwise, omit any leading zeros (i.e., print Fn mod 10000).

Sample Input

0
9
999999999
1000000000
-1

Sample Output

0
34
626
6875

Hint

As a reminder, matrix multiplication is associative, and the product of two 2 × 2 matrices is given by

.

Also, note that raising any 2 × 2 matrix to the 0th power gives the identity matrix:

.

Source


矩阵的方法求斐波那契数列。
方法参照《挑战程序设计竞赛》。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
typedef long long LL;
using namespace std;
#define REPF( i , a , b ) for ( int i = a ; i <= b ; ++ i )
#define REP( i , n ) for ( int i = 0 ; i < n ; ++ i )
#define CLEAR( a , x ) memset ( a , x , sizeof a )
const int MOD=10000;
typedef vector<int>vec;
typedef vector<vec>mat;
LL n;
mat mul(mat A,mat B)
{
    mat C(A.size(),vec(B[0].size()));
    REP(i,A.size())
    {
        REP(j,B[0].size())
        {
            REP(k,B.size())
              C[i][j]=(C[i][j]+A[i][k]*B[k][j])%MOD;
        }
    }
    return C;
}
mat pow(mat A,LL n)
{
    mat B(A.size(),vec(A.size()));
    REP(i,A.size())
       B[i][i]=1;
    while(n>0)
    {
        if(n&1)   B=mul(B,A);
        A=mul(A,A);
        n>>=1;
    }
    return B;
}
void work()
{
    mat A(2,vec(2));
    A[0][0]=1;A[0][1]=1;
    A[1][0]=1;A[1][1]=0;
    A=pow(A,n);
    cout<<A[1][0]<<endl;
}
int main()
{
     std::ios::sync_with_stdio(false);
     while(cin>>n&&n!=-1)
        work();
     return 0;
}


POJ 3070 Fibonacci(矩阵快速幂)