首页 > 代码库 > POJ3641 Pseudoprime numbers 【快速幂】

POJ3641 Pseudoprime numbers 【快速幂】

Pseudoprime numbers
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6644 Accepted: 2696

Description

Fermat‘s theorem states that for any prime number p and for any integer a > 1, ap = a (mod p). That is, if we raise a to the pth power and divide by p, the remainder is a. Some (but not very many) non-prime values of p, known as base-pseudoprimes, have this property for some a. (And some, known as Carmichael Numbers, are base-a pseudoprimes for all a.)

Given 2 < p ≤ 1000000000 and 1 < a < p, determine whether or not p is a base-a pseudoprime.

Input

Input contains several test cases followed by a line containing "0 0". Each test case consists of a line containing p and a.

Output

For each test case, output "yes" if p is a base-a pseudoprime; otherwise output "no".

Sample Input

3 2
10 3
341 2
341 3
1105 2
1105 3
0 0

Sample Output

no
no
yes
no
yes
yes

Source

Waterloo Local Contest, 2007.9.23

#include <stdio.h>
#include <string.h>
#include <math.h>

typedef long long LL;

bool isPrime(int n) {
    if(n < 2) return false;
    int t = sqrt((double)n);
    for(int i = 2; i <= t; ++i)
        if(n % i == 0) return false;
    return true;
}

LL mod_power(LL x, LL n, LL mod) {
    LL ret = 1;
    for( ; n > 0; n >>= 1) {
        if(n & 1) ret = ret * x % mod;
        x = x * x % mod;
    }
    return ret;
}

int main() {
    LL p, a;
    while(scanf("%lld%lld", &p, &a), p | a) {
        if(isPrime(p)) printf("no\n");
        else printf(mod_power(a, p, p) == a ? "yes\n" : "no\n");
    }
    return 0;
}


POJ3641 Pseudoprime numbers 【快速幂】