首页 > 代码库 > hdu2577——How to Type

hdu2577——How to Type

How to Type

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3920    Accepted Submission(s): 1800


Problem Description
Pirates have finished developing the typing software. He called Cathy to test his typing software. She is good at thinking. After testing for several days, she finds that if she types a string by some ways, she will type the key at least. But she has a bad habit that if the caps lock is on, she must turn off it, after she finishes typing. Now she wants to know the smallest times of typing the key to finish typing a string.
 

Input
The first line is an integer t (t<=100), which is the number of test case in the input file. For each test case, there is only one string which consists of lowercase letter and upper case letter. The length of the string is at most 100.
 

Output
For each test case, you must output the smallest times of typing the key to finish typing this string.
 

Sample Input
3 Pirates HDUacm HDUACM
 

Sample Output
8 8 8
Hint
The string “Pirates”, can type this way, Shift, p, i, r, a, t, e, s, the answer is 8. The string “HDUacm”, can type this way, Caps lock, h, d, u, Caps lock, a, c, m, the answer is 8 The string "HDUACM", can type this way Caps lock h, d, u, a, c, m, Caps lock, the answer is 8
 

Author
Dellenge
 

Source
HDU 2009-5 Programming Contest
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  2870 2830 2845 1058 2571 
 

DP题,设dp[i][0]表示当打印第i个字符时大写未锁定,dp[i][1]表示打印第i个字符时大写锁定


如果第i个字符是大写字母

dp[i][0] = min(dp[i - 1][0], dp[i - 1][1]) + 2;

dp[i][1] = min(dp[i - 1][0] + 2, dp[i - 1][1] + 1);

如果第i个字符是小写字母

dp[i][0] = min(dp[i - 1][0] + 1, dp[i - 1][1] + 2);
dp[i][1] = min(dp[i - 1][0], dp[i - 1][1]) + 2;


初始化dp[0][0] = 0,dp[0][1] = 1;

最后输出min(dp[n][0], dp[n][1] + 1)


#include <map>
#include <set>
#include <list>
#include <queue>
#include <stack>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int inf = 0x3f3f3f3f;
int dp[120][2];
char str[120];

int main()
{
	int t;
	scanf("%d", &t);
	while(t--)
	{
		scanf("%s", str);
		int n = strlen(str);
		memset (dp, inf, sizeof(dp));
		dp[0][0] = 0;
		dp[0][1] = 1;
		for (int i = 1; i <= n; i++)
		{
			if (str[i - 1] >= 'A' && str[i - 1] <= 'Z')
			{
				dp[i][0] = min(dp[i - 1][0], dp[i - 1][1]) + 2;
				dp[i][1] = min(dp[i - 1][0] + 2, dp[i - 1][1] + 1);
			}
			else
			{
				dp[i][0] = min(dp[i - 1][0] + 1, dp[i - 1][1] + 2);
				dp[i][1] = min(dp[i - 1][0], dp[i - 1][1]) + 2;
			}
		}
		printf("%d\n", min(dp[n][0], dp[n][1] + 1));
	}
	return 0;
}


hdu2577——How to Type