首页 > 代码库 > HDU1081_To The Max【矩阵压缩】

HDU1081_To The Max【矩阵压缩】

To The Max


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8528    Accepted Submission(s): 4142

Problem Description
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle. In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4 1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1 8

and has a sum of 15.
 
Input
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace (spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will be in the range [-127,127].
 
Output
Output the sum of the maximal sub-rectangle.
 
Sample Input
4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2
 
Sample Output
15
 
Source

Greater New York 2001


题目大意:给你一个N,接下来是N*N的矩阵。数有正有负,求最大的子矩阵

和。

思路:1003题是一维的求连续子序列最大和,dp[i] = max(dp[i-1]+a[i],a[i])

这道题是求二维的子矩阵最大和。考虑将二维转化为一维的。二维数组的每一

行都可以看做一个一维数组。map[i][j]数组上存的是第i行前j列上的和

第k行上,dp[k][i] = max(dp[k][i-1]+map[k][i],map[k][i]),但是这样只能知道

第k行前i个数的最大和是多少,而不知道是第k行上从第几列到第几列上得来的最

大和。状态转移方程换为,以第k行为终点,从第i列到第j列上的最大和

dp[i][j] = max(map[k][j]-map[k][i-1]+dp[i][j],map[k][j]-map[k][i-1]);

然后用一个Max,求出最大的dp[i][j]。因为不涉及求具体的子矩阵的情况,只需

要得到最优解,那么状态转移方程也可以写成

ans = max(map[k][j]-map[k][i-1]+ans,map[k][j]-map[k][i-1]);

ans求的就是是前k行,以第k行为终点,第i到第j列的最大和


第一种代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int map[110][110],dp[110][110];
int main()
{
    int N,a;
    while(~scanf("%d",&N) && N)
    {
        memset(map,0,sizeof(map));
        memset(dp,0,sizeof(dp));
        for(int i = 1; i <= N; i++)
        {
            for(int j = 1; j <= N; j++)
            {
                scanf("%d",&a);
                map[i][j] = map[i][j-1] + a;
                //map[i][j]表示第i行前j列的和
            }
        }
        int Max = -0xffffff0;
        for(int j = 1; j <= N; j++)
        {
            for(int i = 1; i <= j; i++)
            {
                dp[i][j] = 0;
                for(int k = 1; k <= N; k++)
                {
                    //ans求的是前k行,第i到第j列的最大和
                    dp[i][j]= max(dp[i][j]+map[k][j]-map[k][i-1],map[k][j]-map[k][i-1]);
                    if(dp[i][j] > Max)
                        Max = dp[i][j];
                }
            }
        }
        printf("%d\n",Max);
    }
    return 0;
}
第二种代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int map[110][110];
int main()
{
    int N,a;
    while(~scanf("%d",&N) && N)
    {
        memset(map,0,sizeof(map));
        for(int i = 1; i <= N; i++)
        {
            for(int j = 1; j <= N; j++)
            {
                scanf("%d",&a);
                map[i][j] = map[i][j-1] + a;
            }
        }
        int Max = -0xffffff0;
        for(int j = 1; j <= N; j++)
        {
            for(int i = 1; i <= j; i++)
            {
                int ans = 0;
                for(int k = 1; k <= N; k++)
                {
                    ans = max(ans+map[k][j]-map[k][i-1],map[k][j]-map[k][i-1]);
                    if(ans > Max)
                        Max = ans;
                }
            }
        }
        printf("%d\n",Max);
    }
    return 0;
}





HDU1081_To The Max【矩阵压缩】