首页 > 代码库 > poj 1840 简单hash

poj 1840 简单hash

http://poj.org/problem?id=1840

Description

Consider equations having the following form: 
a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0 
The coefficients are given integers from the interval [-50,50]. 
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}. 

Determine how many solutions satisfy the given equation. 

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654
/**
poj 1840  hash

*/
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long LL;
const int maxn=25000008;
int a1,a2,a3,a4,a5;
short hash[maxn*2];///int 就会爆掉内存约束空间复杂度压得很紧
int main()
{
    while(cin>>a1>>a2>>a3>>a4>>a5)
    {
        for(int i=-50;i<=50;i++)
        {
            if(i==0)continue;
            for(int j=-50;j<=50;j++)
            {
                if(j==0)continue;
                for(int k=-50;k<=50;k++)
                {
                    if(k==0)continue;
                    hash[i*i*i*a1+j*j*j*a2+k*k*k*a3+maxn]++;
                }
            }
        }
        LL ans=0;
        for(int i=-50;i<=50;i++)
        {
            if(i==0)continue;
            for(int j=-50;j<=50;j++)
            {
                if(j==0)continue;
                ans+=hash[-i*i*i*a4-j*j*j*a5+maxn];
            }
        }
        cout<< ans<< endl;
    }
    return 0;
}


poj 1840 简单hash