首页 > 代码库 > poj 1577 Falling Leaves

poj 1577 Falling Leaves

Falling Leaves
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4066 Accepted: 2249

Description

 
Figure 1

Figure 1 shows a graphical representation of a binary tree of letters. People familiar with binary trees can skip over the definitions of a binary tree of letters, leaves of a binary tree, and a binary search tree of letters, and go right to The problem. 

A binary tree of letters may be one of two things: 
  1. It may be empty. 
  2. It may have a root node. A node has a letter as data and refers to a left and a right subtree. The left and right subtrees are also binary trees of letters.

In the graphical representation of a binary tree of letters: 
  1. Empty trees are omitted completely. 
  2. Each node is indicated by 
    • Its letter data, 
    • A line segment down to the left to the left subtree, if the left subtree is nonempty, 
    • A line segment down to the right to the right subtree, if the right subtree is nonempty.

A leaf in a binary tree is a node whose subtrees are both empty. In the example in Figure 1, this would be the five nodes with data B, D, H, P, and Y. 

The preorder traversal of a tree of letters satisfies the defining properties: 
  1. If the tree is empty, then the preorder traversal is empty. 
  2. If the tree is not empty, then the preorder traversal consists of the following, in order 
    • The data from the root node, 
    • The preorder traversal of the root‘s left subtree, 
    • The preorder traversal of the root‘s right subtree.

The preorder traversal of the tree in Figure 1 is KGCBDHQMPY. 

A tree like the one in Figure 1 is also a binary search tree of letters. A binary search tree of letters is a binary tree of letters in which each node satisfies: 

The root‘s data comes later in the alphabet than all the data in the nodes in the left subtree. 

The root‘s data comes earlier in the alphabet than all the data in the nodes in the right subtree. 

The problem: 

Consider the following sequence of operations on a binary search tree of letters 

Remove the leaves and list the data removed 
Repeat this procedure until the tree is empty 
Starting from the tree below on the left, we produce the sequence of trees shown, and then the empty tree 

by removing the leaves with data 

BDHPY 
CM 
GQ 


Your problem is to start with such a sequence of lines of leaves from a binary search tree of letters and output the preorder traversal of the tree.

Input

The input will contain one or more data sets. Each data set is a sequence of one or more lines of capital letters. 

The lines contain the leaves removed from a binary search tree in the stages described above. The letters on a line will be listed in increasing alphabetical order. Data sets are separated by a line containing only an asterisk (‘*‘). 

The last data set is followed by a line containing only a dollar sign (‘$‘). There are no blanks or empty lines in the input.

Output

For each input data set, there is a unique binary search tree that would produce the sequence of leaves. The output is a line containing only the preorder traversal of that tree, with no blanks.

Sample Input

BDHPY
CM
GQ
K
*
AC
B
$

Sample Output

KGCBDHQMPY
BAC

题意:题目输入的是一个二叉树,首行把二叉树的所有叶子节点列出来组成一个字符串,如何从去掉叶子节点后形成的新二叉树中再找出叶子节点,再组成一个一个字符串,依次进行下去,知道最后只剩下根节点为止,以*和$为二叉树的输入结束符,题目要求你输出二叉树,输出规则为:先输出根节点,根节点的左儿子,根节点的左儿子的左儿子,根节点的左儿子的左儿子的左儿子,,,,根节点的左儿子的左儿子........的左儿子的左儿子,然后继续输出根节点的左儿子的左儿子........的左儿子的左儿子,根节点的左儿子的左儿子........的左儿子,,,,,;

#include <iostream>
#include <string.h>
using namespace std;
#define MAX 1005
struct node{
	char val;
	node *lch,*rch;
};
char s[MAX];
node *insert(node *p,char val){
	if (p==NULL){
		node *q=new node;
		q->val=val;
		q->lch=q->rch=NULL;
		return q;
	}
	else{
		if (val<p->val)
			p->lch=insert(p->lch,val);
		else
			p->rch=insert(p->rch,val);
		return p;
	}
}
void show(node *p){
	if (p==NULL)
		return;
	cout<<p->val;
	if (p->lch!=NULL)
		show(p->lch);
	if (p->rch!=NULL)
		show(p->rch);
}
int main(){
	while (cin>>s){
		int len=strlen(s);
		char str;
		while (1){
			cin>>str;
			if (str=='*'||str=='$')
				break;
			s[len++]=str;
		}
		node *p=NULL;
		while (len-->0){
			p=insert(p,s[len]);
		}
		show(p);
		cout<<endl;
	}
	return 0;
}


poj 1577 Falling Leaves