首页 > 代码库 > HDOJ-1060-Leftmost Digit(求n^n的最高位)

HDOJ-1060-Leftmost Digit(求n^n的最高位)

<marquee width="600">【科普】什么是BestCoder?如何参加?
</marquee>

Leftmost Digit

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13554    Accepted Submission(s): 5211


Problem Description
Given a positive integer N, you should output the leftmost digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the leftmost digit of N^N.
 

Sample Input
2 3 4
 

Sample Output
2 2
Hint
In the first case, 3 * 3 * 3 = 27, so the leftmost digit is 2.In the second case, 4 * 4 * 4 * 4 = 256, so the leftmost digit is 2.
#include<cstdio>
#include<cstring>
#include <iostream>
#include <math.h>
using namespace std;
int main()
{
    int t;
    while(~scanf("%d",&t))
    {
        while(t--)
        {
            __int64 n;
            cin>>n;
            double x=n*log10(n*1.0); 
            x-=(__int64)x;
            int a=pow(10.0, x);//a为10的小数次方的整数部分 
            cout<<a<<endl;
        }
    }
    return 0; 
}

HDOJ-1060-Leftmost Digit(求n^n的最高位)