首页 > 代码库 > A计划

A计划

Problem Description
可怜的公主在一次次被魔王掳走一次次被骑士们救回来之后,而今,不幸的她再一次面临生命的考验。魔王已经发出消息说将在T时刻吃掉公主,因为他听信谣言说吃公主的肉也能长生不老。年迈的国王正是心急如焚,告招天下勇士来拯救公主。不过公主早已习以为常,她深信智勇的骑士LJ肯定能将她救出。 现据密探所报,公主被关在一个两层的迷宫里,迷宫的入口是S(0,0,0),公主的位置用P表示,时空传输机用#表示,墙用*表示,平地用.表示。骑士们一进入时空传输机就会被转到另一层的相对位置,但如果被转到的位置是墙的话,那骑士们就会被撞死。骑士们在一层中只能前后左右移动,每移动一格花1时刻。层间的移动只能通过时空传输机,且不需要任何时间。
 

Input
输入的第一行C表示共有C个测试数据,每个测试数据的前一行有三个整数N,M,T。 N,M迷宫的大小N*M(1 <= N,M <=10)。T如上所意。接下去的前N*M表示迷宫的第一层的布置情况,后N*M表示迷宫第二层的布置情况。
 

Output
如果骑士们能够在T时刻能找到公主就输出“YES”,否则输出“NO”。
 

Sample Input
1 5 5 14 S*#*. .#... ..... ****. ...#. ..*.P #.*.. ***.. ...*. *.#..
 

Sample Output
YES
#include <iostream>
#include <cstring>
#include <cstdio>
#include <cmath>
using namespace std;
char str[2][20][20];
int len[2][20][20];
//int tp[] = {1, 0, , -1, 0};
int xx[4][2] = {{1, 0}, {0, 1}, { -1, 0}, {0, -1}};
int s, t, n, m;
int x, y, q;
bool flag;
bool bfs(int a, int b, int C, int temp)
{
    int ax, ay, c;
    //cout << C << " " << a - 1 << " " << b - 1 << "  " << temp << endl;
    //getchar();
    if (str[C][a][b] == 'P') {
            //flag=true;
        return 1;
    }
    if (temp <= 0)return 0;
    int sm = abs(a - x) + abs(b - y);
    if (sm > temp)return 0;
    for (int i = 0; i < 4; i++) {
        ax = a + xx[i][0];
        ay = b + xx[i][1];
        c = C;
        if (ax >= 1 && ax <= n && ay >= 1 && ay <= m && !len[c][ax][ay] && str[c][ax][ay] != '*') {
            if (str[c][ax][ay] == '#') {
                c = 1 - c;
            }
            len[c][ax][ay] = 1;
            if (str[c][ax][ay] != '#' && str[c][ax][ay] != '*'&&    bfs(ax, ay, c, temp - 1)) {
                return 1;
            }
            len[c][ax][ay] = 0;
        }
    }
    return 0;
}
int main()
{

    cin >> s;
    while (s--) {
        flag=false;
        memset(len, 0, sizeof(len));
        cin >> n >> m >> t;
        for (int i = 1; i <= n; i++)
            for (int j = 1; j <= m; j++) {
                cin >> str[0][i][j];
                if (str[0][i][j] == 'P') {
                    x = i; y = j; q = 0;
                }
            }
        for (int i = 1; i <= n; i++)
            for (int j = 1; j <= m; j++) {
                cin >> str[1][i][j];
                if (str[1][i][j] == 'P') {
                    x = i; y = j; q = 1;
                }
            }
        if(bfs(1, 1, 0, t))
           cout << "YES" << endl;
        else cout << "NO" << endl;
    }
    return 0;
}