首页 > 代码库 > hdu 1068 Girls and Boys(匈牙利算法求最大独立集)

hdu 1068 Girls and Boys(匈牙利算法求最大独立集)

Girls and Boys

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7044    Accepted Submission(s): 3178


Problem Description
the second year of the university somebody started a study on the romantic relations between the students. The relation “romantically involved” is defined between one girl and one boy. For the study reasons it is necessary to find out the maximum set satisfying the condition: there are no two students in the set who have been “romantically involved”. The result of the program is the number of students in such a set.

The input contains several data sets in text format. Each data set represents one set of subjects of the study, with the following description:

the number of students
the description of each student, in the following format
student_identifier:(number_of_romantic_relations) student_identifier1 student_identifier2 student_identifier3 ...
or
student_identifier:(0)

The student_identifier is an integer number between 0 and n-1, for n subjects.
For each given data set, the program should write to standard output a line containing the result.
 

Sample Input
7 0: (3) 4 5 6 1: (2) 4 6 2: (0) 3: (0) 4: (2) 0 1 5: (1) 0 6: (2) 0 1 3 0: (2) 1 2 1: (1) 0 2: (1) 0
 

Sample Output
5 2
 

题意:在大学校园里男女学生存在某种关系,现在给出学生人数n,并给出每个学生与哪些学生存在关系(存在关系的学生一定是异性)。现在让你求一个学生集合,这个集合中任意两个学生之间不存在这种关系。输出这样的关系集合中最大的一个的学生人数。(网上翻译)
最大独立集问题 :在N个点的图G中选出m个点,使这m个点两两之间没有边.求m的最大值. 如果图G满足二分图条件,则可以用二分图匹配来做.最大独立集点数 = N - 最大匹配数
匈牙利算法
#include"stdio.h"
#include"string.h"
#define N 505
int g[N][N];
int mark[N];
int link[N];
int n;
int find(int k)
{
	int i;
	for(i=0;i<n;i++)
	{
		if(g[i][k]&&!mark[i])
		{
			mark[i]=1;
			if(link[i]==-1||find(link[i]))
			{
				link[i]=k;
				return 1;
			}
		}
	}
	return 0;
}
int main()
{
	int i,j,u,v,m;
	while(scanf("%d",&n)!=-1)
	{
		for(i=0;i<n;i++)
			for(j=0;j<n;j++)
				g[i][j]=0;

		for(i=0;i<n;i++)
		{
			scanf("%d: (%d)",&u,&m);
			while(m--)
			{
				scanf("%d",&v);
				g[u][v]=1;
			}
		}
		memset(link,-1,sizeof(link));
		int ans=0;
		for(i=0;i<n;i++)
		{
			memset(mark,0,sizeof(mark));
			if(find(i))
				ans++;
		}
		printf("%d\n",n-ans/2);
	}
	return 0;
}