首页 > 代码库 > hdu 4352 XHXJ's LIS (数位dp)

hdu 4352 XHXJ's LIS (数位dp)

XHXJ‘s LIS

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 755    Accepted Submission(s): 289


Problem Description
#define xhxj (Xin Hang senior sister(学姐))
If you do not know xhxj, then carefully reading the entire description is very important.
As the strongest fighting force in UESTC, xhxj grew up in Jintang, a border town of Chengdu.
Like many god cattles, xhxj has a legendary life:
2010.04, had not yet begun to learn the algorithm, xhxj won the second prize in the university contest. And in this fall, xhxj got one gold medal and one silver medal of regional contest. In the next year‘s summer, xhxj was invited to Beijing to attend the astar onsite. A few months later, xhxj got two gold medals and was also qualified for world‘s final. However, xhxj was defeated by zhymaoiing in the competition that determined who would go to the world‘s final(there is only one team for every university to send to the world‘s final) .Now, xhxj is much more stronger than ever,and she will go to the dreaming country to compete in TCO final.
As you see, xhxj always keeps a short hair(reasons unknown), so she looks like a boy( I will not tell you she is actually a lovely girl), wearing yellow T-shirt. When she is not talking, her round face feels very lovely, attracting others to touch her face gently。Unlike God Luo‘s, another UESTC god cattle who has cool and noble charm, xhxj is quite approachable, lively, clever. On the other hand,xhxj is very sensitive to the beautiful properties, "this problem has a very good properties",she always said that after ACing a very hard problem. She often helps in finding solutions, even though she is not good at the problems of that type.
Xhxj loves many games such as,Dota, ocg, mahjong, Starcraft 2, Diablo 3.etc,if you can beat her in any game above, you will get her admire and become a god cattle. She is very concerned with her younger schoolfellows, if she saw someone on a DOTA platform, she would say: "Why do not you go to improve your programming skill". When she receives sincere compliments from others, she would say modestly: "Please don’t flatter at me.(Please don‘t black)."As she will graduate after no more than one year, xhxj also wants to fall in love. However, the man in her dreams has not yet appeared, so she now prefers girls.
Another hobby of xhxj is yy(speculation) some magical problems to discover the special properties. For example, when she see a number, she would think whether the digits of a number are strictly increasing. If you consider the number as a string and can get a longest strictly increasing subsequence the length of which is equal to k, the power of this number is k.. It is very simple to determine a single number’s power, but is it also easy to solve this problem with the numbers within an interval? xhxj has a little tired,she want a god cattle to help her solve this problem,the problem is: Determine how many numbers have the power value k in [L,R] in O(1)time.
For the first one to solve this problem,xhxj will upgrade 20 favorability rate。
 

Input
First a integer T(T<=10000),then T lines follow, every line has three positive integer L,R,K.(
0<L<=R<263-1 and 1<=K<=10).
 

Output
For each query, print "Case #t: ans" in a line, in which t is the number of the test case starting from 1 and ans is the answer.
 

Sample Input
1 123 321 2
 

Sample Output
Case #1: 139
 

Author
peterae86@UESTC03
 

Source
2012 Multi-University Training Contest 6
 

题意:
先定义一个数的value,把这个数看成一个字符串,他的最长上升子序列的长度就是他的value,求某个区间内value等于k的数的个数。

思路来源于silver__bullet

思路:
数位dp,先回忆LIS的nlogn解法,我们用dp[len]记录LIS长度为len时的最后一个数的大小,然后不断更新这些值,让每一个值都尽可能小,比如我现在的LIS是1 2 4 6,这时候下一个数是3,那么我们就要更新成1 2 3 6,让前面的数尽可能的小,这样就是为了能让后面的数有更多的机会被加入。
因为数字只有10个,我们可以状态压缩,记录每个数字是否出现在当前的LIS中。
dp[i][j][k]:位数为i 当前LIS的状态为j 要求的上升子序列的长度为k。
枚举当前位是什么来进行转移,注意考虑前导0和是否有上界标记。
k不是LIS的长度,一个状态的LIS长度是一定的,但对于要求的不同的LIS长度,一个状态得到的结果是不同的,所以k为要求的上升子序列的长度。

代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <string>
#include <map>
#include <stack>
#include <vector>
#include <set>
#include <queue>
#define maxn 205
#define MAXN 100005
#define mod 100000000
#define INF 0x3f3f3f3f
#define pi acos(-1.0)
#define eps 1e-6
typedef long long ll;
using namespace std;

ll n,m,ans,tot,le,ri,k;
ll dig[20],dp[20][1<<11][11];

ll getstate(ll s,ll u,ll& xx)  // 状态转移
{
    ll i,ss;
    for(i=u;i<10;i++)
    {
        if(s&(1<<i)) break ;
    }
    if(i<10)
    {
        ss=s^(1<<i);
        ss=ss^(1<<u);
    }
    else
    {
        xx++;
        ss=s^(1<<u);
    }
    return ss;
}
ll dfs(ll pos,ll s,ll len,ll flg,ll lead) // 当前位 LIS状态 LIS长度 上界标志 前导0标志
{
    if(pos==0)
    {
        if(len==k) return 1;
        return 0;
    }
    if(!flg&&dp[pos][s][k]!=-1) return dp[pos][s][k];
    ll i,j,t,ed,res=0;
    if(flg) ed=dig[pos];
    else ed=9;
    for(i=0;i<=ed;i++)
    {
        ll ss,nlen=len;
        if(lead==0&&i==0) ss=0;
        else ss=getstate(s,i,nlen);
        t=dfs(pos-1,ss,nlen,flg&&i==ed,lead||i!=0);
        res+=t;
    }
    if(!flg) dp[pos][s][k]=res;
    return res;
}
ll solve(ll x)
{
    ll i,j,t=x;
    tot=0;
    while(t)
    {
        dig[++tot]=t%10;
        t/=10;
    }
    ll res=dfs(tot,0,0,1,0);
    return res;
}
int main()
{
    ll i,j,t,test=0;
    memset(dp,-1,sizeof(dp));
    scanf("%I64d",&t);
    while(t--)
    {
        scanf("%I64d%I64d%I64d",&le,&ri,&k);
        ans=solve(ri)-solve(le-1);
        printf("Case #%I64d: %I64d\n",++test,ans);
    }
    return 0;
}
/*
10
1 20 1
1 20 2
*/