首页 > 代码库 > HDUJ 1865 1sting

HDUJ 1865 1sting

1sting

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3227    Accepted Submission(s): 1237


Problem Description
You will be given a string which only contains ‘1’; You can merge two adjacent ‘1’ to be ‘2’, or leave the ‘1’ there. Surly, you may get many different results. For example, given 1111 , you can get 1111, 121, 112,211,22. Now, your work is to find the total number of result you can get.
 

Input
The first line is a number n refers to the number of test cases. Then n lines follows, each line has a string made up of ‘1’ . The maximum length of the sequence is 200.
 

Output
The output contain n lines, each line output the number of result you can get .
 

Sample Input
3 1 11 11111
 

Sample Output
1 2 8




import java.util.Scanner;
import java.math.BigInteger;


public class yugtg {  
      
    public static void main(String[] args) {  
        Scanner cin = new Scanner(System.in);
        BigInteger s[] = new BigInteger[205];
        s[1] = new BigInteger("1");
        s[2] = new BigInteger("2");
        for(int i=3;i<=200;i++)
        	s[i] = s[i-1].add(s[i-2]);
        
        int n = cin.nextInt();       
        for(int i=0;i<n;i++)
        {
        	String S = cin.next();
        	int l = S.length();
        	
        	System.out.println(s[l]);
        }
    }  
}