首页 > 代码库 > Bone Collector(dp 01背包)

Bone Collector(dp 01背包)

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave … The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ? [center][img]../../../data/images/C154-1003-1.jpg[/img] [/center]
 

Input
The first line contain a integer T , the number of cases. Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 2[sup]31[/sup]).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
int dp[2000], w[1000], v[1000];
int n, t, m;
int main()
{
    cin >> t;
    while (t--) {
        memset(dp,0,sizeof(dp));
        cin >> n >> m;
        for (int i = 0; i < n; i++) {
            cin >> w[i] ;
        }
      for (int i = 0; i < n; i++) {
            cin >> v[i] ;
        }
        for (int i = 0; i < n; i++)
            for (int j = m; j >= v[i]; j--)
                dp[j] = max(dp[j], dp[j - v[i]] + w[i]);
            cout<<dp[m]<<endl;
    }
    return 0;
}