首页 > 代码库 > 字典树(模型体)
字典树(模型体)
输入
输出
示例输入
5abaabbwabaz
示例输出
2
提示
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <algorithm>
const int N = 20010;
using namespace std;
struct node
{
int flag;
node *next[26];
};
int n,m,ans = 0;
struct node *Creat()
{
node *p = new node;
for(int i=0; i<26; i++ )
{
p->next[i] = NULL;
}
p->flag = 0;
return p;
}
void INsert( node *root, char *b)
{
int num;
int len = strlen(b);
node *p = root;
for(int i = 0;i<len;i++)
{
num = b[i]-‘a‘;
if(p->next[num]==NULL)
{
p->next[num] = Creat();
}
p = p->next[num];
}
p->flag++;
if(p->flag > ans)
ans = p->flag;
}
void FREE(struct node*root)
{
for(int i = 0;i<n;i++)
{
if(root->next[i]!=NULL)
{
FREE(root->next[i]);
}
}
free(root);
}
int main()
{
char a[N][50],s[50];
node *p;
scanf("%d",&m);
p = Creat();
for(int i = 0;i<m;i++)
{
scanf("%s",s);
INsert(p,s);
}
printf("%d\n",ans);
FREE(p);
return 0;
}