首页 > 代码库 > 测试赛B - Balance(天平的dp问题)

测试赛B - Balance(天平的dp问题)

B - Balance
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u
Submit Status

Description

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm‘s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
? the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
? the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-‘ for the left arm and ‘+‘ for the right arm); 
? on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights‘ values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2
dp问题,dp[k][i] 中i = 第k个砝码挂上后左侧的值-右侧的值,因为可能出现右侧的大,i不能为负值,所以计算的i同意+8000 ;
所以dp[m][8000]是挂上m个砝码后仍然平衡的种类
首先dp[0][8000] = 1 ;其余的都是-1为不可达点
逐个计算,最后得到dp[m][8000]
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
int a[22] , b[22] ;
int p[22][16001] ;
int main()
{
    int i , j , k , n , m , l = -1 , r = -1 ;
    scanf("%d %d", &n, &m);
    for(i = 1 ; i <= n ; i++)
    {
        scanf("%d", &a[i]);
        if(l == -1 && a[i] < 0)
            l = i ;
        if(r == -1 && a[i] > 0)
            r = i ;
    }
    for(i = 1 ; i <= m ; i++)
        scanf("%d", &b[i]);
    memset(p,0,sizeof(p));
    p[0][8000] = 1 ;
    for(i = 1 ; i <= m ; i++)
    {
        for(j = 16000 ; j >= 0 ; j--)
        {
            for(k = l ; k < r ; k++)
            {
                int s = j - a[k]*b[i] ;
                if( s <= 16000 )
                    p[i][j] += p[i-1][ s ];
            }
        }
        for(j = 0 ; j <= 16000 ; j++)
        {
            for(k = r ; k <= n ; k++)
            {
                int s = j - a[k]*b[i] ;
                if( s >= 0 )
                p[i][j] += p[i-1][ s ] ;
            }
        }
    }
    printf("%d\n", p[m][8000]);
}