首页 > 代码库 > hdu 1597 find the nth digit

hdu 1597 find the nth digit

find the nth digit

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8363    Accepted Submission(s): 2385


Problem Description
假设:
S1 = 1
S2 = 12
S3 = 123
S4 = 1234
.........
S9 = 123456789
S10 = 1234567891
S11 = 12345678912
............
S18 = 123456789123456789
..................
现在我们把所有的串连接起来
S = 1121231234.......123456789123456789112345678912.........
那么你能告诉我在S串中的第N个数字是多少吗?
 

Input
输入首先是一个数字K,代表有K次询问。
接下来的K行每行有一个整数N(1 <= N < 2^31)。
 

Output
对于每个N,输出S中第N个对应的数字.
 

Sample Input
6 1 2 3 4 5 10
 

Sample Output
1 1 2 1 2 4
 

Author
8600
 

Source
HDU 2007-Spring Programming Contest - Warm Up (1) 
题意:
1
1 2
1 2 3
1 2 3 4
。。。。。
就是求n在sm区间上的值,由于9是循环节,所以最后的结果要mod 9
举个例子,假设n=4,其中要求它值我们会发现它是减去前两层的个数。
#include<iostream>
using namespace std;
int main()
{
    int t,n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        for(int i=1;i<n;i++)
            n-=i;
        n=n%9;
        if(n)
            cout<<n<<endl;
        else
            cout<<9<<endl;
    }
    return 0;
}