首页 > 代码库 > POJ 2318 TOYS

POJ 2318 TOYS

TOYS
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9955 Accepted: 4754

Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John‘s parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.

Source

Rocky Mountain 2003


题目大意:

第一行n,m,x1,x2,y1,y2,表示有个玩具收纳盒被n个线段分为n+1块,编号依次是0,1,2....n,这个收纳盒的左上角坐标是x1,y1,右下角是x2,y2,接下来n行u0,l0,是指给你这些线段的坐标,(u0,y1)与(l0,y2) ,紧接着是m行,表示玩具的坐标,问你每一块玩具的个数

解题思路:

利用二分求出玩具所在哪一块,因为在左边或者在右边,满足单调性,利用叉积算出在左边还是右边。

解题代码:

#include <iostream>
#include <vector>
#include <cstdio>
using namespace std;

const int maxn=5100;

struct point{
    int x,y;
    point(int x0=0,int y0=0){
        x=x0;y=y0;
    }
    int xchen(point a,point b){//pa*pb
        int x1=a.x-x,y1=a.y-y,x2=b.x-x,y2=b.y-y;
        return x1*y2-x2*y1;
    }
};

struct line{
    point p1,p2;
    line(point p10,point p20){
        p1=p10;p2=p20;
    }
};

int n,m,ans[maxn];
vector <line> v;

void input(){
    v.clear();
    int x1,y1,x2,y2,u0,l0;
    scanf("%d%d%d%d%d",&m,&x1,&y1,&x2,&y2);
    for(int i=0;i<=n;i++) ans[i]=0;
    for(int i=0;i<n;i++){
        scanf("%d%d",&u0,&l0);
        v.push_back(line(point(u0,y1),point(l0,y2)));
    }
}

void solve(){
    point p;
    for(int i=0;i<m;i++){
        scanf("%d%d",&p.x,&p.y);
        if( (v[0].p1).xchen(v[0].p2,p) < 0 ) ans[0]++;
        else if( (v[n-1].p1).xchen(v[n-1].p2,p) > 0  ) ans[n]++;
        else{
            int l=0,r=n-1;
            while(l<r){
                int mid=(l+r)/2;
                if( (v[mid].p1).xchen(v[mid].p2,p) > 0 ) l=mid+1;
                else r=mid;
            }
            ans[r]++;
        }
    }
    for(int i=0;i<=n;i++){
        printf("%d: %d\n",i,ans[i]);
    }
}

int main(){
    int casen=0;
    while(scanf("%d",&n)!=EOF && n!=0){
        input();
        casen++;
        if(casen>1) printf("\n");
        solve();
    }
    return 0;
}