首页 > 代码库 > Fibonacci Again

Fibonacci Again

Fibonacci Again

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : 8   Accepted Submission(s) : 3
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

 

Sample Input
0
1
2
3
4
5
 

 

Sample Output
no
no
yes
no
no
no
 
 
code:

#include<stdio.h>
int f[1000001];
int main()
{
     int n,i;
     while(scanf("%d",&n)!=EOF)
    {
             f[0]=7,f[1]=11;
           if(n==0||n==1)
                printf("no\n");
          else
         {
                for(i=2;i<=1000000;i++)
                     f[i]=(f[i-1]%3+f[i-2]%3)%3;
               if(f[n]==0)
                     printf("yes\n");
               else
                     printf("no\n");
        }
     }
    return 0;
}

 

余数里面的一条公式:(a+b)%3 = (a%3+b%3)%3

 

Wrong Answer:

 

#include<stdio.h>
int f[1000000];
int main()
{
        int n,i;
       while(scanf("%d",&n)!=EOF)
       {
             if(n==0||n==1)
                printf("no\n");
             else
             {
                  f[0]=7,f[1]=11;
                 for(i=2;i<=n;i++)
                      f[i]=f[i-1]+f[i-2];
                 if(f[n]%3==0)
                     printf("yes\n");
                 else
                    printf("no\n");
             }
       }
    return 0;
}