首页 > 代码库 > HDU 3074-Multiply game(线段树:单点更新,区间求积)

HDU 3074-Multiply game(线段树:单点更新,区间求积)

Multiply game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1450    Accepted Submission(s): 508


Problem Description
Tired of playing computer games, alpc23 is planning to play a game on numbers. Because plus and subtraction is too easy for this gay, he wants to do some multiplication in a number sequence. After playing it a few times, he has found it is also too boring. So he plan to do a more challenge job: he wants to change several numbers in this sequence and also work out the multiplication of all the number in a subsequence of the whole sequence.
  To be a friend of this gay, you have been invented by him to play this interesting game with him. Of course, you need to work out the answers faster than him to get a free lunch, He he…

 

Input
The first line is the number of case T (T<=10).
  For each test case, the first line is the length of sequence n (n<=50000), the second line has n numbers, they are the initial n numbers of the sequence a1,a2, …,an, 
Then the third line is the number of operation q (q<=50000), from the fourth line to the q+3 line are the description of the q operations. They are the one of the two forms:
0 k1 k2; you need to work out the multiplication of the subsequence from k1 to k2, inclusive. (1<=k1<=k2<=n) 
1 k p; the kth number of the sequence has been change to p. (1<=k<=n)
You can assume that all the numbers before and after the replacement are no larger than 1 million.
 

Output
For each of the first operation, you need to output the answer of multiplication in each line, because the answer can be very large, so can only output the answer after mod 1000000007.
 

Sample Input
1 6 1 2 4 5 6 3 3 0 2 5 1 3 7 0 2 5
 

Sample Output
240 420
注意使用long long 即可。
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cctype>
#include <cmath>
#include <cstdlib>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <list>
#define L long long
using namespace std;
const int mod=1000000007;
const int INF=1<<27;
const int maxn=300500;
L mul[maxn];
void update(int root,int l,int r,int p,int v)
{
	int mid=(l+r)/2;
	if(l==r) mul[root]=v;
	if(l<r)
	{
		if(p<=mid) update(root*2,l,mid,p,v);
		else update(root*2+1,mid+1,r,p,v);
		mul[root]=(mul[root*2]*mul[root*2+1])%mod;
	}
}
L query_mul(int root,int l,int r,int ql,int qr)
{
	L ans=1;int mid=(l+r)/2;
	if(ql<=l&&qr>=r) return mul[root];
	if(ql<=mid) ans=(ans*query_mul(root*2,l,mid,ql,qr))%mod;
	if(qr>mid) ans=(ans*query_mul(root*2+1,mid+1,r,ql,qr))%mod;
	return ans;
}
int main()
{
	char op;
	int n,m,ql,qr,i,v,p,T;
	scanf("%d",&T);
	while(T--)
    {
    	scanf("%d",&n);
    	for(i=1;i<=n;i++)
		{
			scanf("%d",&v);
			update(1,1,n,i,v);
		}
		scanf("%d",&m);
		while(m--)
		{
			getchar();
			scanf("%c",&op);
			if(op=='0')
			{
			  scanf("%d%d",&ql,&qr);
			  printf("%lld\n",query_mul(1,1,n,ql,qr));
			}
			else if(op=='1')
			{
				scanf("%d%d",&p,&v);
				update(1,1,n,p,v);
			}
		}
    }
	return 0;
}