首页 > 代码库 > Candy( 数学期望 )

Candy( 数学期望 )

Candy

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1830    Accepted Submission(s): 794
Special Judge


Problem Description
LazyChild is a lazy child who likes candy very much. Despite being very young, he has two large candy boxes, each contains n candies initially. Everyday he chooses one box and open it. He chooses the first box with probability p and the second box with probability (1 - p). For the chosen box, if there are still candies in it, he eats one of them; otherwise, he will be sad and then open the other box.
He has been eating one candy a day for several days. But one day, when opening a box, he finds no candy left. Before opening the other box, he wants to know the expected number of candies left in the other box. Can you help him?
 

Input
There are several test cases.
For each test case, there is a single line containing an integer n (1 ≤ n ≤ 2 × 105) and a real number p (0 ≤ p ≤ 1, with 6 digits after the decimal).
Input is terminated by EOF.
 

Output
For each test case, output one line “Case X: Y” where X is the test case number (starting from 1) and Y is a real number indicating the desired answer.
Any answer with an absolute error less than or equal to 10-4 would be accepted.
 

Sample Input
10 0.400000 100 0.500000 124 0.432650 325 0.325100 532 0.487520 2276 0.720000
 

Sample Output
Case 1: 3.528175 Case 2: 10.326044 Case 3: 28.861945 Case 4: 167.965476 Case 5: 32.601816 Case 6: 1390.500000 防止溢出 活用log 取自然数对
#include<iostream>
#include<cstdio>
#include<cstring>
# include<string>
# include<cmath>
using namespace std;
//typedef __int64  lld;
const int maxn=400010+5;
int n;
double q;
double p;
double c[maxn];
double C(int x, int y)
{
     return c[x]-c[y]-c[x-y];
}

double v1(int x )
{
     return    C(2*n-x,n)+(n+1)*log(q*1.0)+(n-x)*log(p*1.0);
}
double v2(int y)
{
    return   C(2*n-y,n) + (n+1)*log(p*1.0)+(n-y)*log(q*1.0);
}
int main()
{

      int k=0;
       c[0]=0;
       for( int i=1; i<400010; i++)
            c[i]=c[i-1]+log(i*1.0);

    while(cin>>n>>q)
    {
       k++;
       double tot=0;
         p=1-q;
        for(int  i=n; i>0;i--)
        {
            tot+=i*( exp(v1(i))+exp(v2(i)) );
        }

        printf("Case %d: %lf\n",k,tot);

    }
    return 0;
}

#include<stdio.h>
#include<string.h>
#include<math.h>
#define N 400200
double f[N];
double logc(int n,int m)
{
    return f[m]-f[n]-f[m-n];
}
int main ()
{
    int n;
    int i,j,k=0;
    double p,ans,ret;
    f[0]=0;
    for (i=1;i<N;++i) f[i]=f[i-1]+log(1.0*i);
    while (scanf("%d%lf",&n,&p)!=EOF)
    {
        ans=0;
        double p1=log(p),p2=log(1-p);
        double q1=(n+1)*p1,q2=(n+1)*p2;
        for (i=0;i<n;++i)
        {
            ans+=((n-i)*exp(logc(n,n+i)+q1+i*p2));
            ans+=((n-i)*exp(logc(n,n+i)+q2+i*p1));
        }
        printf("Case %d: %.6lf\n",++k,ans);
    }
    return 0;
}


Candy( 数学期望 )