首页 > 代码库 > 拓扑排序 HDU 2647

拓扑排序 HDU 2647

注意顺序

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4289    Accepted Submission(s): 1311


Problem Description
Dandelion‘s uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.
The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a‘s reward should more than b‘s.Dandelion‘s unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work‘s reward will be at least 888 , because it‘s a lucky number.
 

Input
One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)
then m lines ,each line contains two integers a and b ,stands for a‘s reward should be more than b‘s.
 

Output
For every case ,print the least money dandelion ‘s uncle needs to distribute .If it‘s impossible to fulfill all the works‘ demands ,print -1.
 

Sample Input
2 1 1 2 2 2 1 2 2 1
 

Sample Output
1777 -1
 

#include <stdio.h>
#include <stdlib.h>
#include <malloc.h>
#include <limits.h>
#include <ctype.h>
#include <string.h>
#include <string>
#include <math.h>
#include <algorithm>
#include <iostream>
#include <queue>
#include <stack>
#include <deque>
#include <vector>
#include <set>
#include <map>
using namespace std;
#define MAXN 10011
int money[MAXN];
int head[MAXN];
int into[MAXN];

struct node{
    int to;
    int next;
}edge[20010];

int main(){
    int n,m;
    int i,j;

    while(~scanf("%d%d",&n,&m)){
        for(i=1;i<=n;i++){
            money[i] = 888;
        }
        memset(into,0,sizeof(into));
        memset(head,-1,sizeof(head));
        int k = 0;
        while(m--){
            scanf("%d%d",&j,&i);
            edge[k].to = j;
            edge[k].next = head[i];
            head[i] = k++;
            into[j]++;
        }
        queue<int>t;
        for(i=1;i<=n;i++){
            if(into[i] == 0){
                t.push(i);
            }
        }
        int num = 0;
        int ans = 0;
        while(!t.empty()){
            int u = t.front();
            ans+=money[u];
            t.pop();
            num++;
            for(k=head[u];k!=-1;k=edge[k].next){
                if(--into[edge[k].to] == 0){//--的位置注意
                    t.push(edge[k].to);
                    money[edge[k].to] = money[u] + 1;
                }
                //t.push(edge[k].to);
                //money[edge[k].to] = money[u] + 1;
            }
        }
        if(num != n){
            ans = -1;
        }
        printf("%d\n",ans);
    }

    return 0;
}


拓扑排序 HDU 2647