首页 > 代码库 > poj 2506 Tiling

poj 2506 Tiling

Tiling
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7461 Accepted: 3645

Description

In how many ways can you tile a 2xn rectangle by 2x1 or 2x2 tiles? 
Here is a sample tiling of a 2x17 rectangle. 

Input

Input is a sequence of lines, each line containing an integer number 0 <= n <= 250.

Output

For each line of input, output one integer number in a separate line giving the number of possible tilings of a 2xn rectangle. 

Sample Input

2
8
12
100
200

Sample Output

3
171
2731
845100400152152934331135470251
1071292029505993517027974728227441735014801995855195223534251

Source

The UofA Local 2000.10.14
大数递归直接用java打表就行了
import java.math.BigInteger;
import java.util.Scanner;


public class Main {

	public static void main(String[] args) {
		Scanner cin=new Scanner(System.in);
		BigInteger[] ans=new BigInteger[300];
		ans[0]=BigInteger.ONE;
		ans[1]=BigInteger.ONE;
		int n;
			for(int i=2;i<ans.length;i++)
				ans[i]=(ans[i-1].add(ans[i-2])).add(ans[i-2]);
			while(cin.hasNext())
			{
     			n=cin.nextInt();
				System.out.println(ans[n]);
			}

	}

}