首页 > 代码库 > poj 2431 Expedition

poj 2431 Expedition

Expedition
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 7255 Accepted: 2163

Description

A group of cows grabbed a truck and ventured on an expedition deep into the jungle. Being rather poor drivers, the cows unfortunately managed to run over a rock and puncture the truck‘s fuel tank. The truck now leaks one unit of fuel every unit of distance it travels. 

To repair the truck, the cows need to drive to the nearest town (no more than 1,000,000 units distant) down a long, winding road. On this road, between the town and the current location of the truck, there are N (1 <= N <= 10,000) fuel stops where the cows can stop to acquire additional fuel (1..100 units at each stop). 

The jungle is a dangerous place for humans and is especially dangerous for cows. Therefore, the cows want to make the minimum possible number of stops for fuel on the way to the town. Fortunately, the capacity of the fuel tank on their truck is so large that there is effectively no limit to the amount of fuel it can hold. The truck is currently L units away from the town and has P units of fuel (1 <= P <= 1,000,000). 

Determine the minimum number of stops needed to reach the town, or if the cows cannot reach the town at all. 

Input

* Line 1: A single integer, N 

* Lines 2..N+1: Each line contains two space-separated integers describing a fuel stop: The first integer is the distance from the town to the stop; the second is the amount of fuel available at that stop. 

* Line N+2: Two space-separated integers, L and P

Output

* Line 1: A single integer giving the minimum number of fuel stops necessary to reach the town. If it is not possible to reach the town, output -1.

Sample Input

4
4 4
5 2
11 5
15 10
25 10

Sample Output

2

Hint

INPUT DETAILS: 

The truck is 25 units away from the town; the truck has 10 units of fuel. Along the road, there are 4 fuel stops at distances 4, 5, 11, and 15 from the town (so these are initially at distances 21, 20, 14, and 10 from the truck). These fuel stops can supply up to 4, 2, 5, and 10 units of fuel, respectively. 

OUTPUT DETAILS: 

Drive 10 units, stop to acquire 10 more units of fuel, drive 4 more units, stop to acquire 5 more units of fuel, then drive to the town.

题目意思:有一群牛开车去探险,现在油箱坏了,每走1个单位长度需要消耗1个单位油,急需修理,要去距离当前位置L的town,现在有P单位的油,在这条路上有N个加油点,现在知道每个加油点距离town的距离和可以加油的最大量,请选择一种策略使得停车加油的次数最少。

题解:在卡车开往终点的途中,只有在加油站才可以加油,但是,如果认为“在到达加油站i时,就获得了一次在之后的任何时候都可以加Bi单位汽油的权利”,在解决问题上应该也是一样的。而在之后需要加油时,就可以认为是在之前经过的加油站加的油就可以了。那么,因为洗完到达终点是加油次数尽可能的少,所以当燃料为0了之后再进行加油看上去是一个不错的方法。在燃料为0 时,选择加油量Bi最大的加油站加油;

注意:输入不是按照有序的顺序输入,需要先排序;

#include <iostream>
#include <algorithm>
#include <queue>
using namespace std;
int n,l,p;
struct sl{
	int a,b;
}s[100005]; 
bool cmp(sl x,sl y){
	if (x.a<y.a)
		return true;
	return false;	
}
void solve(){
	s[n].a=l;
	s[n].b=0;
	n++;
	sort(s,s+n,cmp);
	priority_queue<int> que;
	int ans=0,pos=0,tank=p;
	for (int i=0;i<n;i++){
		
		int d=s[i].a-pos;
		while (tank-d<0){
			if (que.empty()){
				cout<<-1<<endl;
				return ;
			}
			tank+=que.top();
			que.pop();
			ans++;
		}
		tank-=d;
		pos=s[i].a;
		que.push(s[i].b);
	}
	cout<<ans<<endl;
}
int main(){
	
	while (cin>>n){
		for (int i=0;i<n;i++)
			cin>>s[i].a>>s[i].b;
		cin>>l>>p;
		for(int i=0;i<n;i++)
			s[i].a=l-s[i].a;
		solve();
	}
	
	return 0;
}




poj 2431 Expedition