首页 > 代码库 > hdu4496 D-City(反向并查集)

hdu4496 D-City(反向并查集)

转载请注明出处:http://blog.csdn.net/u012860063

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=4496



D-City

Problem Description
Luxer is a really bad guy. He destroys everything he met.
One day Luxer went to D-city. D-city has N D-points and M D-lines. Each D-line connects exactly two D-points. Luxer will destroy all the D-lines. The mayor of D-city wants to know how many connected blocks of D-city left after Luxer destroying the first K D-lines in the input.
Two points are in the same connected blocks if and only if they connect to each other directly or indirectly.
 
Input
First line of the input contains two integers N and M.
Then following M lines each containing 2 space-separated integers u and v, which denotes an D-line.
Constraints:
0 < N <= 10000
0 < M <= 100000
0 <= u, v < N.
 
Output
Output M lines, the ith line is the answer after deleting the first i edges in the input.
 
Sample Input
5 10 0 1 1 2 1 3 1 4 0 2 2 3 0 4 0 3 3 4 2 4
 

Sample Output
1 1 1 2 2 2 2 3 4 5
Hint
The graph given in sample input is a complete graph, that each pair of vertex has an edge connecting them, so there‘s only 1 connected block at first. The first 3 lines of output are 1s because after deleting the first 3 edges of the graph, all vertexes still connected together. But after deleting the first 4 edges of the graph, vertex 1 will be disconnected with other vertex, and it became an independent connected block. Continue deleting edges the disconnected blocks increased and finally it will became the number of vertex, so the last output should always be N.
 

Source
2013 ACM-ICPC吉林通化全国邀请赛——题目重现 

/*题目不是很难,只需要逆向思考(正向行不通的时候,我们不防换一条路
试试,生活亦是如此);我们可以逆向认为所有的点全是独立的,因为正
向的时候去掉其中某条边的,独立的点不一定会增多(去掉这条边后还有
其他边间接的相连),所以当我们逆向思考的时候,只会在增加某一条边
时减少独立的点(也就是联通的点增多),这样只会在他之后才会有可能
有某条边的操作是“无效”的(联通的点不变);*/
//并查集!
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;

#define M 10047
int father[M];
int ans[M];//记录独立的点数
struct node
{
	int l,r;
}P[100047];

int find(int x)
{
	return x == father[x]?x:father[x]=find(father[x]);
}

int main()
{
	int n, m, i, j, t;
	while(~scanf("%d%d",&n,&m))
	{
		t = n;
		for(i = 0; i <= n; i++)
		{
			father[i] = i;
		}
		for(i = m-1; i >= 0; i--)//注意此处的i是从大到小的,把去掉边的操作逆向存储在结构体中
		{						 //这样就能达到上面说得逆向思考
			scanf("%d%d",&P[i].l,&P[i].r);
		}
		for(i = 0; i < m; i++)   //因为记录的边已经逆向,这里就不再需要
		{
			int f1 = find(P[i].l);
			int f2 = find(P[i].r);
			if(f2 != f1)
			{
				father[f1] = f2;
				t--;            //当有新增的边使独立的点减少的时候
			}
			ans[i] = t;
		}
		for(i = m - 2; i >= 0; i--)
		{
			printf("%d\n",ans[i]); //逆向输出
		}
		printf("%d\n",n);
	}
	return 0;
}