首页 > 代码库 > POJ3311——Hie with the Pie

POJ3311——Hie with the Pie

Hie with the Pie
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 4646 Accepted: 2457

Description

The Pizazz Pizzeria prides itself in delivering pizzas to its customers as fast as possible. Unfortunately, due to cutbacks, they can afford to hire only one driver to do the deliveries. He will wait for 1 or more (up to 10) orders to be processed before he starts any deliveries. Needless to say, he would like to take the shortest route in delivering these goodies and returning to the pizzeria, even if it means passing the same location(s) or the pizzeria more than once on the way. He has commissioned you to write a program to help him.

Input

Input will consist of multiple test cases. The first line will contain a single integern indicating the number of orders to deliver, where 1 ≤ n ≤ 10. After this will ben + 1 lines each containing n + 1 integers indicating the times to travel between the pizzeria (numbered 0) and then locations (numbers 1 to n). The jth value on the ith line indicates the time to go directly from location i to locationj without visiting any other locations along the way. Note that there may be quicker ways to go fromi to j via other locations, due to different speed limits, traffic lights, etc. Also, the time values may not be symmetric, i.e., the time to go directly from locationi to j may not be the same as the time to go directly from locationj to i. An input value of n = 0 will terminate input.

Output

For each test case, you should output a single number indicating the minimum time to deliver all of the pizzas and return to the pizzeria.

Sample Input

3
0 1 10 10
1 0 1 2
10 1 0 10
10 2 10 0
0

Sample Output

8

Source

East Central North America 2006


经典TSP问题,状压dp外加floyd

#include <map>
#include <set>
#include <list>
#include <stack>
#include <queue>
#include <vector>
#include <cmath>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>

using namespace std;

const int inf = 0x3f3f3f3f;
int dp[2100][15];
int floyd[15][15];

int main()
{
	int n;
	while (~scanf("%d", &n), n)
	{
		memset ( floyd, inf, sizeof(floyd) );
		memset ( dp, inf, sizeof(dp) );
		for (int i = 0; i <= n; ++i)
		{
			for (int j = 0; j <= n; ++j)
			{
				scanf("%d", &floyd[i][j]);
			}
		}
		for (int k = 0; k <= n; ++k)
		{
			for (int i = 0; i <= n; ++i)
			{
				for (int j = 0; j <= n; ++j)
				{
					floyd[i][j] = min(floyd[i][j], floyd[i][k] + floyd[k][j]);
				}
			}
		}
		dp[0][0] = 0;
		for (int i = 0; i < (1 << (1 + n)); ++i)
		{
			for (int j = 0; j <= n; ++j)
			{
				for (int k = 0; k <= n; ++k)
				{
					if ( (i & (1 << j)) == 0 )
					{
						dp[i | (1 << j)][j] = min(dp[i | (1 << j )][j], dp[i][k] + floyd[k][j]);
					}
				}
			}
		}
		printf("%d\n", dp[(1 << (n + 1)) - 1][0]);
	}
	return 0;
}


POJ3311——Hie with the Pie