首页 > 代码库 > Hdu 1018 Big Number
Hdu 1018 Big Number
Big Number
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)Total Submission(s): 26727 Accepted Submission(s): 12160
Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.
Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.
Output
The output contains the number of digits in the factorial of the integers appearing in the input.
Sample Input
21020
Sample Output
719
由斯特林[striling]公式可得:lnN!=NlnN-N+0.5ln(2N*pi)
而N的阶乘的位数等于:log10(N!)取整后加1
log10(N!)=lnN!/ln(10) 所以len=lnN!/ln(10)+1
公式就是强大!#include<iostream>
#include<cmath>
using namespace std;
#define pi acos(-1.0)
int main()
{
int t,n;
cin>>t;
while(t--&&cin>>n)
{
double sum = (n*log(n)-n+0.5*log(2*n*pi))/log(10);
cout<<(int)sum+1<<endl;
}
return 0;
}
#include<cmath>
using namespace std;
#define pi acos(-1.0)
int main()
{
int t,n;
cin>>t;
while(t--&&cin>>n)
{
double sum = (n*log(n)-n+0.5*log(2*n*pi))/log(10);
cout<<(int)sum+1<<endl;
}
return 0;
}
Hdu 1018 Big Number
声明:以上内容来自用户投稿及互联网公开渠道收集整理发布,本网站不拥有所有权,未作人工编辑处理,也不承担相关法律责任,若内容有误或涉及侵权可进行投诉: 投诉/举报 工作人员会在5个工作日内联系你,一经查实,本站将立刻删除涉嫌侵权内容。