首页 > 代码库 > HDU 1018

HDU 1018

Big Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27270    Accepted Submission(s): 12384


Problem Description
In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number.

Input
Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 ≤ n ≤ 107 on each line.

Output
The output contains the number of digits in the factorial of the integers appearing in the input.

Sample Input
2 10 20

Sample Output
7 19

Source
Asia 2002, Dhaka (Bengal)

 

求的是N的阶乘一共有几位数。。

明显大数问题。。主要思想:

比如 5 的阶乘。

1*2*3*4*5 是个三位数  可以看成ln1+ln2+ln3+ln4+ln5  =ln120。 ln 120 显然是大于二小于三的。所以只要int(ln(N!))+1就是答案。杭电上这题数据绝逼坑,同一个代码有的跑了951MS,有的超时。所以我下面的代码不一定能过,用G++提交吧,多提交两次可能就过了。技术分享

 

234B的都是同一个代码,有的AC了。有的超时了。C++编译过不了。上代码

#include <stdio.h>
#include <math.h>
int main()
{
    int n,m,i;
    double sum;
    scanf("%d",&n);
    while(n--)
    {
        sum=0;
        scanf("%d",&m);
        for(i=1;i<=m;i++)
            sum+=log10(i);
        printf("%d\n",(int)(sum)+1);
    }
    return 0;
}


 

HDU 1018