首页 > 代码库 > POJ 1651 Multiplication Puzzle(区间dp)

POJ 1651 Multiplication Puzzle(区间dp)

Multiplication Puzzle
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 6542 Accepted: 3983

Description

The multiplication puzzle is played with a row of cards, each containing a single positive integer. During the move player takes one card out of the row and scores the number of points equal to the product of the number on the card taken and the numbers on the cards on the left and on the right of it. It is not allowed to take out the first and the last card in the row. After the final move, only two cards are left in the row. 

The goal is to take cards in such order as to minimize the total number of scored points. 

For example, if cards in the row contain numbers 10 1 50 20 5, player might take a card with 1, then 20 and 50, scoring 
10*1*50 + 50*20*5 + 10*50*5 = 500+5000+2500 = 8000

If he would take the cards in the opposite order, i.e. 50, then 20, then 1, the score would be 
1*50*20 + 1*20*5 + 10*1*5 = 1000+100+50 = 1150.

Input

The first line of the input contains the number of cards N (3 <= N <= 100). The second line contains N integers in the range from 1 to 100, separated by spaces.

Output

Output must contain a single integer - the minimal score.

Sample Input

6
10 1 50 50 20 5

Sample Output

3650

Source

Northeastern Europe 2001, Far-Eastern Subregion

题意:
给你n个数,每次从中抽出一个数(第一和最后一个不能抽),该次的得分即为抽出的数与相邻两个数的乘积。直到只剩下首尾两个数为止。问最小得分是多少?

题解:
区间dp的思想,枚举区间长度,每次保存最优解。

AC Code:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<set>
#include<queue>
#include<stack>
#include<vector>
#include<map>

#define N 100010
#define Mod 10000007
#define lson l,mid,idx<<1
#define rson mid+1,r,idx<<1|1
#define lc idx<<1
#define rc idx<<1|1
const double EPS = 1e-11;
const double PI = acos ( -1.0 );
const double E = 2.718281828;
typedef long long ll;

const ll INF = 1010010010100101001;

using namespace std;

ll dp[110][110];
ll  a[110];
int n;

int main()
{
    while ( cin >> n )
    {
        for ( int i = 1; i <= n; i++ )
            scanf ( "%I64d", &a[i] );
        memset ( dp, 0, sizeof dp );
        for ( int l = 2; l < n; l++ )
        {
            for ( int i = 1, j = i + l; j <= n; j++, i++ )
            {
                dp[i][j] = INF;
                for ( int k = i + 1; k < j; k++ )
                    dp[i][j] = min ( dp[i][j], dp[i][k] + dp[k][j] + a[i] * a[j] * a[k] );
            }
        }
        cout << dp[1][n] << endl;
    }
    return 0;
}


POJ 1651 Multiplication Puzzle(区间dp)