首页 > 代码库 > HDUJ 1316 How Many Fibs?

HDUJ 1316 How Many Fibs?

How Many Fibs?

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 4106    Accepted Submission(s): 1623


Problem Description
Recall the definition of the Fibonacci numbers:
f1 := 1
f2 := 2
fn := fn-1 + fn-2 (n >= 3)

Given two numbers a and b, calculate how many Fibonacci numbers are in the range [a, b].
 

Input
The input contains several test cases. Each test case consists of two non-negative integer numbers a and b. Input is terminated by a = b = 0. Otherwise, a <= b <= 10^100. The numbers a and b are given with no superfluous leading zeros.
 

Output
For each test case output on a single line the number of Fibonacci numbers fi with a <= fi <= b.
 

Sample Input
10 100 1234567890 9876543210 0 0
 

Sample Output
5 4



import java.util.Scanner;
import java.math.BigInteger;


public class yhrtr {

	public static void main(String[] args) {
		Scanner cin = new Scanner (System.in);
		BigInteger s[] = new BigInteger[1010];
		s[1] = new BigInteger("1");
		s[2] = new BigInteger("2");
		for(int i=3;i<=1005;i++)
			s[i] = s[i-1].add(s[i-2]);
		
		BigInteger a,b,c;
		while(cin.hasNext())
		{
			a = cin.nextBigInteger();
			b = cin.nextBigInteger();
			if(a.compareTo(BigInteger.ZERO)==0 && b.compareTo(BigInteger.ZERO)==0)
				return ;
			if(a.compareTo(b)>0)
			{
				c = a;
				a = b;
				b = c;
			}
			
			int sum = 0;
			for(int i=1;i<=1005;i++)
			{
				if(s[i].compareTo(a)>=0 && s[i].compareTo(b)<=0)
					sum++;
			}
			System.out.println(sum);
		}
	}
}