首页 > 代码库 > HDU4861 Couple doubi 【找规律】

HDU4861 Couple doubi 【找规律】

Couple doubi

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 723    Accepted Submission(s): 522


Problem Description
DouBiXp has a girlfriend named DouBiNan.One day they felt very boring and decided to play some games. The rule of this game is as following. There are k balls on the desk. Every ball has a value and the value of ith (i=1,2,...,k) ball is 1^i+2^i+...+(p-1)^i (mod p). Number p is a prime number that is chosen by DouBiXp and his girlfriend. And then they take balls in turn and DouBiNan first. After all the balls are token, they compare the sum of values with the other ,and the person who get larger sum will win the game. You should print “YES” if DouBiNan will win the game. Otherwise you should print “NO”.
 

Input
Multiply Test Cases.
In the first line there are two Integers k and p(1<k,p<2^31).
 

Output
For each line, output an integer, as described above.
 

Sample Input
2 3 20 3
 

Sample Output
YES NO

在演草纸上分别列出p为3、5、7的情况,可以找到规律,即周期为p-1,每p-1个数里面只有一个数不等于0,于是可以求有多少个周期,周期数为奇数则先手赢。

#include <stdio.h>
#include <math.h>
int main()
{
    int k, p;
    while(scanf("%d%d", &k, &p) != EOF){
        if(k / (p-1) % 2) printf("YES\n");
        else printf("NO\n");
    }
    return 0;
}


HDU4861 Couple doubi 【找规律】