首页 > 代码库 > poj1789Truck History(最小生成树prim算法)

poj1789Truck History(最小生成树prim算法)

题目链接:

啊哈哈,点我点我

思路:根据字符串中不同的长度建图,然后求图的最小生成树。。

题目:

Truck History
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18272 Accepted: 7070

Description

Advanced Cargo Movement, Ltd. uses trucks of different types. Some trucks are used for vegetable delivery, other for furniture, or for bricks. The company has its own code describing each type of a truck. The code is simply a string of exactly seven lowercase letters (each letter on each position has a very special meaning but that is unimportant for this task). At the beginning of company‘s history, just a single truck type was used but later other types were derived from it, then from the new types another types were derived, and so on. 

Today, ACM is rich enough to pay historians to study its history. One thing historians tried to find out is so called derivation plan -- i.e. how the truck types were derived. They defined the distance of truck types as the number of positions with different letters in truck type codes. They also assumed that each truck type was derived from exactly one other truck type (except for the first truck type which was not derived from any other type). The quality of a derivation plan was then defined as 
1/Σ(to,td)d(to,td)

where the sum goes over all pairs of types in the derivation plan such that to is the original type and td the type derived from it and d(to,td) is the distance of the types. 
Since historians failed, you are to write a program to help them. Given the codes of truck types, your program should find the highest possible quality of a derivation plan. 

Input

The input consists of several test cases. Each test case begins with a line containing the number of truck types, N, 2 <= N <= 2 000. Each of the following N lines of input contains one truck type code (a string of seven lowercase letters). You may assume that the codes uniquely describe the trucks, i.e., no two of these N lines are the same. The input is terminated with zero at the place of number of truck types.

Output

For each test case, your program should output the text "The highest possible quality is 1/Q.", where 1/Q is the quality of the best derivation plan.

Sample Input

4
aaaaaaa
baaaaaa
abaaaaa
aabaaaa
0

Sample Output

The highest possible quality is 1/3.

Source

CTU Open 2003


代码为:

#include<cstdio>
#include<iostream>
#include<cstring>
#define INF 0x3f3f3f3f
using namespace std;

const int maxn=2000+10;
int dis[maxn],gra[maxn][maxn],vis[maxn],n;

struct Node
{
   char  car_number[10+10];
}node[maxn];

int caldistance(Node a,Node b)
{
    int k=0;
    for(int i=0;i<7;i++)
       if(a.car_number[i]!=b.car_number[i])
         k++;
    return k;
}

void prim()
{
   int tmp,now,ans=0;
   memset(dis,0x3f,sizeof(dis));
   memset(vis,0,sizeof(vis));
   for(int i=1;i<=n;i++)
      dis[i]=INF;
   dis[1]=0;
   for(int i=1;i<=n;i++)
   {
       tmp=INF;
       for(int j=1;j<=n;j++)
       {
           if(!vis[j]&&tmp>dis[j])
           {
               now=j;
               tmp=dis[j];
           }
       }
       vis[now]=1;
       ans=ans+tmp;
       for(int j=1;j<=n;j++)
       {
           if(!vis[j]&&dis[j]>gra[now][j])
                dis[j]=gra[now][j];
       }
   }
   printf("The highest possible quality is 1/%d.\n",ans);
}


void read_graph()
{
    int temp;
    for(int i=1;i<n;i++)
        for(int j=i+1;j<=n;j++)
        {
            temp=caldistance(node[i],node[j]);
            gra[i][j]=gra[j][i]=temp;
        }
}


int main()
{
    while(~scanf("%d",&n),n)
    {
        for(int i=1;i<=n;i++)
            scanf("%s",node[i].car_number);
        read_graph();
        prim();
    }
    return 0;
}