首页 > 代码库 > POJ2914 Minimum Cut 【全局最小割】(Stoer_Wagner)

POJ2914 Minimum Cut 【全局最小割】(Stoer_Wagner)

Minimum Cut
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 7610 Accepted: 3203
Case Time Limit: 5000MS

Description

Given an undirected graph, in which two vertices can be connected by multiple edges, what is the size of the minimum cut of the graph? i.e. how many edges must be removed at least to disconnect the graph into two subgraphs?

Input

Input contains multiple test cases. Each test case starts with two integers N and M (2 ≤ N ≤ 500, 0 ≤ M ≤ N × (N ? 1) ? 2) in one line, where N is the number of vertices. Following are M lines, each line contains M integersAB and C (0 ≤ AB < NA ≠ BC > 0), meaning that there C edges connecting vertices A and B.

Output

There is only one line for each test case, which contains the size of the minimum cut of the graph. If the graph is disconnected, print 0.

Sample Input

3 3
0 1 1
1 2 1
2 0 1
4 3
0 1 1
1 2 1
2 3 1
8 14
0 1 1
0 2 1
0 3 1
1 2 1
1 3 1
2 3 1
4 5 1
4 6 1
4 7 1
5 6 1
5 7 1
6 7 1
4 0 1
7 3 1

Sample Output

2
1
2

Source

Baidu Star 2006 Semifinal 
Wang, Ying (Originator) 
Chen, Shixi (Test cases)

题意:求裸的最小割。

题解:过程有点像求“最大生成树”,每次找到将最后的点(即割点值最小的点)隔离出去的最小割大小nowcut,然后用nowcut更新结果mincut,然后将最后两个点合并,方式是将最后一个点合并到倒数第二个点,边也都合并过去,就这样循环下去直到只剩下一个顶点,此时mincut即为所求。

#include <stdio.h>
#include <string.h>
#define inf 0x7fffffff
#define maxn 502

int map[maxn][maxn], W[maxn], hash[maxn];
bool vis[maxn];

void getMap(int n, int m)
{
    int i, u, v, c;
    memset(map, 0, sizeof(map));
    for(i = 0; i < m; ++i){
        scanf("%d%d%d", &u, &v, &c);
        map[u][v] += c; map[v][u] += c;
    }
}

int Stoer_Wagner(int n)
{
    int minCut = inf, nowCut, now, pre, i, j;
    for(i = 0; i < n; ++i) hash[i] = i;
    while(n > 1){
        nowCut = -1; now = 1; vis[hash[0]] = 1; pre = 0;
        for(i = 1; i < n; ++i){
            W[hash[i]] = map[hash[0]][hash[i]];
            vis[hash[i]] = 0;
            if(W[hash[i]] > nowCut){
                nowCut = W[hash[i]]; now = i;
            }
        }
        for(j = 1; j < n; ++j){
            vis[hash[now]] = 1;
            if(j == n - 1){
                if(nowCut < minCut) minCut = nowCut;
                for(i = 0; i < n; ++i){
                    map[hash[pre]][hash[i]] += map[hash[now]][hash[i]];
                    map[hash[i]][hash[pre]] += map[hash[now]][hash[i]];
                }
                hash[now] = hash[--n];
                break;
            }
            pre = now; nowCut = -1;
            for(i = 1; i < n; ++i){
                if(!vis[hash[i]]){
                    W[hash[i]] += map[hash[pre]][hash[i]];
                    if(W[hash[i]] > nowCut){
                        nowCut = W[hash[i]]; now = i;
                    }
                }
            }
        }
    }
    return minCut;
}

void solve(int n)
{
    printf("%d\n", Stoer_Wagner(n));
}

int main()
{
    freopen("stdin.txt", "r", stdin);
    int n, m;
    while(scanf("%d%d", &n, &m) == 2){
        getMap(n, m);
        solve(n);
    }
    return 0;
}


POJ2914 Minimum Cut 【全局最小割】(Stoer_Wagner)