首页 > 代码库 > POJ 1988 Cube Stacking

POJ 1988 Cube Stacking

题目来源:http://poj.org/problem?id=1988


Cube Stacking
Time Limit: 2000MS Memory Limit: 30000K
Total Submissions: 19173 Accepted: 6693
Case Time Limit: 1000MS

Description

Farmer John and Betsy are playing a game with N (1 <= N <= 30,000)identical cubes labeled 1 through N. They start with N stacks, each containing a single cube. Farmer John asks Betsy to perform P (1<= P <= 100,000) operation. There are two types of operations: 
moves and counts. 
* In a move operation, Farmer John asks Bessie to move the stack containing cube X on top of the stack containing cube Y. 
* In a count operation, Farmer John asks Bessie to count the number of cubes on the stack with cube X that are under the cube X and report that value. 

Write a program that can verify the results of the game. 

Input

* Line 1: A single integer, P 

* Lines 2..P+1: Each of these lines describes a legal operation. Line 2 describes the first operation, etc. Each line begins with a ‘M‘ for a move operation or a ‘C‘ for a count operation. For move operations, the line also contains two integers: X and Y.For count operations, the line also contains a single integer: X. 

Note that the value for N does not appear in the input file. No move operation will request a move a stack onto itself. 

Output

Print the output from each of the count operations in the same order as the input file. 

Sample Input

6
M 1 6
C 1
M 2 4
M 2 6
C 3
C 4

Sample Output

1
0
2

Source

USACO 2004 U S Open

题解: 向量并查集~~~  与Vijos 1443 银河英雄传说无异~~ 这次真爽,一遍打下来没有任何修改就AC了。

AC代码:
#include<cstdio>
const int Max=30001;
int father[Max],loc[Max],root[Max],t,x,y;
char ch;
int find(int k){
	if(k==father[k]) return k;
	int temp=find(father[k]);
	loc[k]+=loc[father[k]];
	father[k]=temp;
	return temp;
}
int main(){
	scanf("%d",&t);
	for(int i=1;i<Max;i++){
		father[i]=i;loc[i]=0;root[i]=1;
	}
	while(t--){
		getchar();
		scanf("%c",&ch);
	if(ch=='M'){
		scanf("%d%d",&x,&y);
		int tempx=find(x),tempy=find(y);
		father[tempy]=tempx;  
		loc[tempy]=root[tempx];
		root[tempx]+=root[tempy];
	}
	else {
		scanf("%d",&x);
		int tempx=find(x);
		printf("%d\n",root[tempx]-loc[x]-1);
	}
	}
	return 0;
} 

  

POJ 1988 Cube Stacking