首页 > 代码库 > bzoj1014:[JSOI2008]火星人prefix

bzoj1014:[JSOI2008]火星人prefix

Description

  火星人最近研究了一种操作:求一个字串两个后缀的公共前缀。比方说,有这样一个字符串:madamimadam,
我们将这个字符串的各个字符予以标号:序号: 1 2 3 4 5 6 7 8 9 10 11 字符 m a d a m i m a d a m 现在,
火星人定义了一个函数LCQ(x, y),表示:该字符串中第x个字符开始的字串,与该字符串中第y个字符开始的字串
,两个字串的公共前缀的长度。比方说,LCQ(1, 7) = 5, LCQ(2, 10) = 1, LCQ(4, 7) = 0 在研究LCQ函数的过程
中,火星人发现了这样的一个关联:如果把该字符串的所有后缀排好序,就可以很快地求出LCQ函数的值;同样,
如果求出了LCQ函数的值,也可以很快地将该字符串的后缀排好序。 尽管火星人聪明地找到了求取LCQ函数的快速
算法,但不甘心认输的地球人又给火星人出了个难题:在求取LCQ函数的同时,还可以改变字符串本身。具体地说
,可以更改字符串中某一个字符的值,也可以在字符串中的某一个位置插入一个字符。地球人想考验一下,在如此
复杂的问题中,火星人是否还能够做到很快地求取LCQ函数的值。

Input

  第一行给出初始的字符串。第二行是一个非负整数M,表示操作的个数。接下来的M行,每行描述一个操作。操
作有3种,如下所示
1、询问。语法:Qxy,x,y均为正整数。功能:计算LCQ(x,y)限制:1<=x,y<=当前字符串长度。
2、修改。语法:Rxd,x是正整数,d是字符。功能:将字符串中第x个数修改为字符d。限制:x不超过当前字
符串长度。
3、插入:语法:Ixd,x是非负整数,d是字符。功能:在字符串第x个字符之后插入字符d,如果x=0,则在字
符串开头插入。限制:x不超过当前字符串长度

Output

  对于输入文件中每一个询问操作,你都应该输出对应的答案。一个答案一行。

Sample Input

madamimadam
7
Q 1 7
Q 4 8
Q 10 11
R 3 a
Q 1 7
I 10 a
Q 2 11

Sample Output

5
1
0
2
1

HINT

 

1、所有字符串自始至终都只有小写字母构成。

2、M<=150,000

3、字符串长度L自始至终都满足L<=100,000

4、询问操作的个数不超过10,000个。

对于第1,2个数据,字符串长度自始至终都不超过1,000

对于第3,4,5个数据,没有插入操作。

 

费尽千方百计终于把这道题A了……

题解:

插入和修改时用splay维护每个区间的hash(具体更新操作见代码)

LCQ可以二分求出:每次二分一个答案,判断时分别旋转看两个区间的hash值是否一样

 

注意:

1.update某区间hash值时不要忘了先赋成0(我是用指针写的)

2.不要忘了GetPow啊,检查时很不容易查出来,还以为自己是对的

3.由于前后都加了一个点,询问时若x=y得出的答案便会比标准答案多1,需要特判一下

4.询问操作x可能大于y,要判一下

5.bzoj不能用cin,bzoj不能用cin,bzoj不能用cin!(重要的事说三遍!!!为此我满篇的RE啊……说起来都是泪555)

 

代码:

#include<cstdio>
#include<iostream>
#include<string.h>
using namespace std;

const int MAXN=140005;
struct node
{
    int d,size;
    int h;
    node *parent,*ch[2];       
}pool[MAXN],*rf,*root;
int cnt,pow[MAXN];
void GetPow()
{
    pow[0]=1;
    for(int i=1;i<MAXN;i++)
        pow[i]=(long long)pow[i-1]*137%10000007;
}
int size(node *p)
{
    if(p) return p->size;
    return 0;
}
void update(node *p)
{
    p->size=1+size(p->ch[0])+size(p->ch[1]);
    p->h=0;
    if(p->ch[0]) p->h=p->ch[0]->h;
    p->h=((long long)p->h*pow[1]+p->d)%10000007;
    if(p->ch[1]) p->h=((long long)p->h*pow[size(p->ch[1])]+p->ch[1]->h)%10000007;
}
void rotate(node *p,int type)
{
    node *parent=p->parent,*son=p->ch[!type],*gp=p->parent->parent;
    parent->ch[type]=son;
    if(son) son->parent=parent;
    p->ch[!type]=parent;
    parent->parent=p;
    p->parent=gp;
    gp->ch[parent==gp->ch[1]]=p;
    update(parent);
    update(p);
    if(parent==root) root=p; 
}
void splay(node *p,node *target)
{
    while(p->parent!=target)
    {
        if(p->parent->parent==target)
            rotate(p,p==p->parent->ch[1]);
        else
        {
            node *parent=p->parent,*gp=p->parent->parent;
            int f=parent==gp->ch[0];
            if(p==parent->ch[f]) rotate(p,f),rotate(p,!f);
            else rotate(parent,!f),rotate(p,!f);   
        }
    }
}
node *find(node *p,int k)
{
    if(size(p->ch[0])>=k) return find(p->ch[0],k);
    else if(size(p->ch[0])==k-1) return p;
    else return find(p->ch[1],k-1-size(p->ch[0]));     
}
void insert(int x,node *newnode)
{
    node *p=find(root,x);
    splay(p,rf);
    p=find(root,x+1);
    splay(p,root);
    p->ch[0]=newnode;
    newnode->parent=p;
    update(p);
    update(p->parent);
}
void change(int x,int d)
{
    node *p=find(root,x);
    splay(p,rf);
    p->d=d;
    update(p);
}
bool query(int x,int y,int dis)
{
    if(dis==-1) return true;
    node *p=find(root,x-1);
    splay(p,rf);
    p=find(root,x+dis+1);
    splay(p,root);
    int hash1=p->ch[0]->h;
    p=find(root,y-1);
    splay(p,rf);
    p=find(root,y+dis+1);
    splay(p,root);
    if(p->ch[0]->h==hash1) return true;
    return false;
}
int Query(int x,int y)
{
    if(x>y) swap(x,y);
    int s=-1,t=size(root)-y-1,mid;
    while(s<t)
    {
        mid=(s+t+1)/2;
        if(query(x,y,mid)) s=mid;
        else t=mid-1;
    }
    return s+1;
}

int main()
{
    char ch1[100000],sh[1],sh1[1];
    int i,m,x,y,len;
    node *p;
    scanf("%s",ch1);
    len=strlen(ch1);
    
    GetPow();
    rf=&pool[++cnt];
    root=&pool[++cnt];
    root->d=root->h=0;
    root->size=1;
    root->parent=rf;
    rf->ch[0]=root;
    for(i=0;i<len;i++)
    {
        p=&pool[++cnt];
        p->d=p->h=ch1[i]-a+1;
        p->size=1;
        root->ch[1]=p;
        p->parent=root;
        splay(p,rf);
    }
    p=&pool[++cnt];
    p->d=p->h=0;p->size=1;
    root->ch[1]=p;
    p->parent=root;
    splay(p,rf);
    
    scanf("%d",&m);
    while(m --> 0)
    {
        scanf("%s",sh);
        if(sh[0]==Q)
        {
            scanf("%d%d",&x,&y);
            x++;y++;
            if(x!=y) printf("%d\n",Query(x,y));
            else printf("%d\n",size(root)-x);
        }
        else if(sh[0]==R)
        {    
            scanf("%d",&x);scanf("%s",sh1);
            x++;
            change(x,sh1[0]-a+1);
        }
        else
        {
            scanf("%d",&x);scanf("%s",sh1);
            x++;
            p=&pool[++cnt];
            p->d=p->h=sh1[0]-a+1;
            p->size=1;
            insert(x,p);
        }
    }
    
    return 0;
}

 

bzoj1014:[JSOI2008]火星人prefix