首页 > 代码库 > HDU 1028 Ignatius and the Princess III

HDU 1028 Ignatius and the Princess III

Description

"Well, it seems the first problem is too easy. I will let you know how foolish you are later." feng5166 says. 

"The second problem is, given an positive integer N, we define an equation like this: 
  N=a[1]+a[2]+a[3]+...+a[m]; 
  a[i]>0,1<=m<=N; 
My question is how many different equations you can find for a given N. 
For example, assume N is 4, we can find: 
  4 = 4; 
  4 = 3 + 1; 
  4 = 2 + 2; 
  4 = 2 + 1 + 1; 
  4 = 1 + 1 + 1 + 1; 
so the result is 5 when N is 4. Note that "4 = 3 + 1" and "4 = 1 + 3" is the same in this problem. Now, you do it!" 
 

Input

The input contains several test cases. Each test case contains a positive integer N(1<=N<=120) which is mentioned above. The input is terminated by the end of file. 
 

Output

For each test case, you have to output a line contains an integer P which indicate the different equations you have found. 
 

Sample Input

41020
 

Sample Output

542627
 
代码是zxp那搬来的 完全不明觉厉= =
#include<cstdio>#include<cstring>#include<iostream>#include<algorithm>using namespace std;__int64 a[150];int main(){    int i,j;    a[0]=1;//a[1]=1;a[2]=2;a[3]=3;a[4]=5;a[5]=7;    for(i=1;i<=120;i++)    {        for(j=0;i+j<=120;j++)        {            a[i+j]+=a[j];        }    }    int n;    while(scanf("%d",&n)!=EOF)    {       printf("%I64d\n",a[n]);    }    return 0;}
View Code

 

HDU 1028 Ignatius and the Princess III