首页 > 代码库 > nyoj 791 Color the fence 【贪心】

nyoj 791 Color the fence 【贪心】

Color the fence

时间限制:1000 ms  |  内存限制:65535 KB
难度:2
描述

Tom has fallen in love with Mary. Now Tom wants to show his love and write a number on the fence opposite to 

Mary’s house. Tom thinks that the larger the numbers is, the more chance to win Mary’s heart he has.

Unfortunately, Tom could only get V liters paint. He did the math and concluded that digit i requires ai liters paint. 

Besides,Tom heard that Mary doesn’t like zero.That’s why Tom won’t use them in his number.

Help Tom find the maximum number he can write on the fence.

输入
There are multiple test cases.
Each case the first line contains a nonnegative integer V(0≤V≤10^6).
The second line contains nine positive integers a1,a2,……,a9(1≤ai≤10^5).
输出
Printf the maximum number Tom can write on the fence. If he has too little paint for any digit, print -1.
样例输入
55 4 3 2 1 2 3 4 529 11 1 12 5 8 9 10 6
样例输出
5555533

代码:

 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

int s[10];
int main(){
	int t, n;
	while(scanf("%d", &n) == 1){
		int i, min = 0x3f3f3f3f;
		for(i = 1; i < 10; i ++){
			scanf("%d", &s[i]);
			if(min > s[i]) min = s[i];
		}
		if(n < min){
			printf("-1\n");
			continue;
		}
		for(i = n/min-1; i >= 0; i --){  //从最多可以染的数目开始
			for(int j = 9; j > 0; j --){
				if(n >= s[j]&&(n-s[j])/min >= i){  //扫描所有的可以满足大于当前要染的数字,以及所要消耗的之后的剩余对min除还能保持>=i,就可以染当前的数字。
					printf("%d", j);
					n-=s[j];
					break;
				}
			}
		}
		printf("\n");
	}
	return 0;
}         


nyoj 791 Color the fence 【贪心】